1

We have created one .app application which will place some files under the user location “/Users//Library/” on executing that. Basically, that app is a shell script app in which .app file is created by using the platypus tool on Mac.

While double clicking the created .app file we are getting the popup below.

enter image description here

We know that this error can sort out by change the Security & Private setting under System Preferences. But, as we are going to share this .app to our customers, we don’t want our customer to do that settings change. Is there any way to avoid this popup? I mean by code level or by doing any kind of code sign?

We have tried to sign the code with self signed certificate, apple developement certificate and Mac developement certificate but facing that issue still.

2
  • 2
    The direct answer to your question is right click the app & select Open - however, I'll leave it to someone else regarding the certificate, which is beyond my expertise - but would be the long-term solution.
    – Tetsujin
    Oct 23 '19 at 15:13
  • Are you a certified Apple Developer? If not, your customers are going to have to use Security & Privacy to make the settings change.
    – IconDaemon
    Oct 23 '19 at 15:59
1

The issue is that using a self-signed certificate does makes you a « identified developer » (at least to the eyes of macOS)

The system only accounts for certificates which have an Apple CA as their root.

If you want to get rid of the pop-up, ask for a Certificate on Apple’s Developer Console and sign your app with it.

Another way is to use csrutil to completly bypass macOS’ security mechanisms, but I highly discourage you from doing this, nor telling your end-users to do so...


Bypassing the security of an OS with a self-signed certificate would make the system... well, unsecure !

By using their CA in the certificates they issue through their Developer Program, they can revoke any app (or developer) at any time, allowing them to ensure the system security when someone tries to do bad stuff.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .