When I installed the VSCode I had added it to dock applications.

I am not able to find it/open it with Alfred or Spotlight. I tried to search for: code, VSCode, visual studio code, and nothing. It seems like if I remove VSCode from dock, I won't be able to start it again.

Any idea?

  • It is possible that 1 Spotlight index is incomplete, it will take some time. or 2 The folder with VSC is hidden in Spotlight Preferences -> Privacy. There might be other things too, these are the first two steps, I think.
    – anki
    Oct 21 '19 at 20:04
  • Welcome to Ask Different. Have you tried to add the VSCode folders to the Spotlight index manually?
    – fsb
    Oct 21 '19 at 20:05
  • Spotlight less important for me then Alfred currently. Checked the privacy settings and there's no limitation. Oct 21 '19 at 20:07
  • Have you contacted the developer of that software for help?
    – fsb
    Oct 22 '19 at 0:18
  • go to system preferences and click on Spotlight. and then click on the tab "search results". This is where you pick folders to search. There should be an entry for Applications. make sure it is checked.
    – Natsfan
    Oct 22 '19 at 3:05

I had the same problem and just managed to fix it.

I went to System Preferences > Spotlight > Search Results and then unchecked "Applications", then re-checked "Applications" and it instantly fixed the problem.


I had the same issue, turns out VSCode app was in the bin. I put it back in Applications and Spotlight found it right away.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .