6

I recently got Mojave. Could somebody tell me whether it's possible to disable the use of the "com.apple.quarantine" extended attribute, for all apps that I have now or will ever download in the future? Thanks!

| improve this question | | | | |
6

If I understood your question clearly, here is the solution that you can use to disable it completely.

  1. Open Terminal
  2. Type following command

    sudo defaults write com.apple.LaunchServices LSQuarantine -bool NO
    
  3. After that, reboot, and you should be set.

If you want to disable quarantine for files already downloaded

  1. Open Terminal.
  2. Execute the following command:

    xattr -l /path/to/application/applicationName.app
    
  3. You will see output similar to:

    enter image description here

To remove an extended attribute manually, type the following command in Terminal

   xattr -d com.apple.quarantine /path/to/application/applicationName.app
| improve this answer | | | | |
  • 1
    @Tetsujin and Udhy - This command looks familiar from the last time I used OS X (El Capitan back in 2016!). Ironically, I've just realised that this isn't the massive issue that it first seemed to be, since I now have all apps that I need installed and not nagging me. But if/when I find the need to install another, I'll let you guys know if it does indeed work. However, Udhy can have the accepted answer rep for now :-) Tetsujin, thanks anyway for trying to help and for being "fastest gun in the west"...perhaps the fastest gun I've ever seen on a SE site! – Kenny83 Oct 21 '19 at 17:56
  • Hmm...nope that command doesn't actually seem to have helped - just downloaded a new .pkg installer and still got the dialog, even after right-clicking as suggested by @Tetsujin :-( I guess I can live with the annoyance of the popup dialog now, since I will rarely download/install anything else on this Mac. Just wanted to warn future readers that another solution is necessary. – Kenny83 Oct 30 '19 at 12:43
  • Thank you! xattr -d com.apple.quarantine MyApp.app was the only way to allow my application to access its resource files. Apparently the quarantine flag prevents chdir calls, which I use to load resources in the directory adjacent to the app. Is this why everyone releases Mac software in dmg images, to avoid Apple stupidly tagging everything extracted from zip files? Such a pain. – Raptor007 May 7 at 6:07
3

First run, instead of double-clicking, right click & select Open.

Done.

Alternatively, disable SIP & you get this option back, in Security & Privacy…

enter image description here

… though you still get some 'are you sure?' messages, you can just say 'OK'

After comments: You may also need to set this in Terminal

sudo defaults write /Library/Preferences/com.apple.security GKAutoRearm -bool NO

From Permanently allow apps downloaded from "anywhere"

| improve this answer | | | | |
  • Dude, I would seriously give you +1000 votes if I could. Will definitely accept this answer as soon as I'm able (in 6 minutes apparently lol). Thank you so much! – Kenny83 Oct 21 '19 at 16:02
  • Actually it seems as though disabling SIP on Mojave doesn't actually bring back that "anywhere" option...I've disabled it, restarted and still can't allow from anywhere :-( – Kenny83 Oct 21 '19 at 16:31
  • hmmm… maybe I also did this… apple.stackexchange.com/a/198123/85275 - adding to answer – Tetsujin Oct 21 '19 at 16:35
  • OK will give that a go...thanks again :-) – Kenny83 Oct 21 '19 at 16:55
  • Wish you luck - let us know how it goes. The pic, btw, was from my own Mojave Mac, so I've obviously managed to do it at some point… I just don't remember quite how ;) – Tetsujin Oct 21 '19 at 16:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .