After Catalina upgrade I have noticed my keyboard layout is different. I was using Croatian (e.g. Y was Z, @ was opt+shift+2).

Now it is switched to "Croatian - PC" which resembles Windows keyboard layout (Y is still Z, @ is opt+v).

There is another option, which is "Croatian" and is similar to what I had before, but with some changes (Y is Y, @ is opt+2).

Is there a way without some external tool and re-mappings to revert my keyboard to what it was before?

  • 1
    Same problem here. After update for Catalina my USB Microsoft Wired 600 (Portuguese), have a completely different mapping. E.g.: ``` < now is § > now is ± \ now is < | now is > € now is æ ``` And so on... I already look for drivers in MS website, but I just found for win 10. I'm also looking for a solution for remap.
    – djayor
    Commented Oct 20, 2019 at 0:44
  • @djayor Your problem sounds different. What exactly do you have on your list in system preferences/keyboard/input sources? What "flag" is showing at the top right of the screen? Commented Oct 20, 2019 at 17:18

1 Answer 1


I have put of copy of the Croatian layout from an earlier MacOS, named "Old Croatian", here and a copy of the Croatian PC layout here. Hopefully one of them will help.

  • Thanks Tom. Is it possible to import this file without Ukulele?
    – Norgul
    Commented Oct 20, 2019 at 19:36
  • 1
    @Norgul Sure, you just put .keylayout files in Home/Library/Keyboard Layouts, logout/login, and activate via the input sources preference pane. They will be in the "others" folder. Commented Oct 20, 2019 at 20:29
  • That worked great. Do you know if it is possible to use one of the "other"-s as a primary input method? I can't seem to remove what was primary before, even though I have added this new one on the list (and am using it)
    – Norgul
    Commented Oct 21, 2019 at 7:53
  • 1
    @Norgul Have a look at this: apple.stackexchange.com/questions/44913/… Commented Oct 21, 2019 at 12:41
  • Moving to /Library/Keyboard Layouts instead of ~/Library/Keyboard Layouts helped. Thanks
    – Norgul
    Commented Oct 21, 2019 at 17:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .