67

The Music app which was introduced in Catalina continuously starts automatically on my Mac. It launches suddenly while I use the mac. The system doesn’t launch the app at the time of the startup.

I tried the followings:

  • Shutdown and restart the system.
  • SMC and PRAM reset.

The Music app cannot be deleted so it is very frustrating to see the app start automatically and play the music.

Is there any way to stop it from launching automatically? This question is not about the app being launched when you plug your iPhone to your Mac either.


UPDATED

I found out that Siri is also launched from time to time.

UPDATED 2

For Siri, I disabled it from System Preferences and it stopped popping up. However, the Music app keeps popping up and there is no solution yet.

4
  • 6
    Music starts for me when I close a zoom meeting. I suspect that Music sees my bluetooth headset as being available and thinks I must want to listen to music. Jan 27, 2020 at 14:32
  • 1
    Same happens to me, whenever I connect my wireless headset, music app launches automatically, which I hate.
    – Zee
    Mar 31, 2020 at 12:38
  • This happened to me 3 times with in two minutes. I am going to start killing with with a signal 11 so that it get a fault that will need to be reported to Apple. May 18, 2020 at 19:26
  • happens to me with Big Sur and iOS 14.2 and Ear Pods connected to the phone. When I end a call on the phone, Music starts on macOS. Very annoying.
    – seafoxx
    Dec 10, 2020 at 15:51

8 Answers 8

40

I have had this experience and I discovered that my finger was lightly brushing the "Play" button on the MacBook Pro's Touchbar. If the current app has no hook for that button, it seems that macOS now choses to launch the Music app.

The solution should be to run launchctl unload -w /System/Library/LaunchAgents/com.apple.rcd.plist. See this howtogeek for details.

Alternatively, you can use noTunes from Tom Taylor to prevent iTunes or Apple Music from launching automatically.

6
  • 4
    For me this disabled the play/pause button for other apps as well, rendering the key useless. Does anyone know of a way to prevent Apple Music from being the fallback choice for the play/pause key? Apr 16, 2020 at 15:09
  • 1
    For me, it did work for the play/pause button. I got Vox to respond to it instead of Music. The problem is Music still responds to play button on my headphones. Aug 18, 2020 at 21:31
  • 3
    This is not the correct answer. The application starts when I turn on my bluetooth headset. I have a separate keyboard station and my finger is nowhere near the touchbar Sep 14, 2020 at 8:38
  • 2
    I'm guessing that activiting Bluetooth headphone triggers the default music source to start playing. I don't have this experience with Apple AirPods so it might be you can configure the headset to not autostart playing when turned on. Sep 14, 2020 at 9:07
  • I had a similar issue. It turns out that the play button on my earbuds were laying up against the body of my laptop and certain keystrokes nudged the body, which pushed the button on the headphones thus launching the Music app. I was looking all over for why, scouring shortcut setting etc. thinking I was accidentally hitting one that might launch that app. Your clue about the play button is what tipped me off to the correct solution: move headphones away from the computer. Gotta love a low tech solution.
    – Andrew
    Apr 8, 2021 at 14:49
16

I found this in github and it works as expected on Catalina:

https://github.com/tombonez/noTunes

Enjoy!

2
  • 1
    Exactly what I searched without breaking my system by blocking some settings or services: Stop starting the Music app when I press the mute button on my Bose Headphones.
    – RiZKiT
    Nov 2, 2021 at 14:55
  • I use airpods when looking at youtube/plex, and will start/stop those videos using the double-tap on my airpods. However, occasionally I'll accidentally close those windows, and then double-tap my airpods--triggering the music app to open. This app fixes that--the double-tap just does nothing if I have no appropriate app open (the correct behavior, imo). Note that download/install using brew failed, but installing from the zip worked.
    – snuggles
    Nov 21, 2021 at 12:56
3

This answer prevents Music.app from opening on startup, which is what the OP originally asked before editing the question.

There are three ways (that I know of).

The first method is going to System Preferences -> Users and Groups -> Login Items and clicking the - button when selecting an application to remove it from startup.

The second method is to right-click the application in your Dock, then uncheck Options -> Open At Login.

The final method is going to Finder, LaunchDaemons in:

/System/Library/LaunchDaemons

and deleting the .plist file for the music app.

You may also need to remove it from:

/Library/LaunchAgents

5
  • 9
    Sorry if my question was not obvious, but what I meant is that the app keeps launching even if I have never opened it and also even though I closed it manually.
    – Blaszard
    Oct 18, 2019 at 23:09
  • 1
    This seems to answer Music app starts at login. But you didnt make it clear in the question, when does it launch? @Blaszard
    – anki
    Oct 18, 2019 at 23:16
  • 3
    @ankii It launches suddenly while I use the mac. The system doesn’t launch the app at the time of the startup.
    – Blaszard
    Oct 18, 2019 at 23:34
  • @blaszard oh, I didn't see that you edited your question. I thought you meant launching on startup. I'll edit my answer then. Apr 1, 2020 at 1:49
  • and deleting the .plist file for the music app --which one is that? I don't see com.apple.music...
    – ZX9
    Jan 21 at 16:22
1

I have a MacBook Pro (Retina, 15-inch, Mid 2014).

I had this problem when I was using wired headphones in the headphone socket. The Music app would start automatically when my finger brushed that side of the case, as if it thought that I had pressed the headphones 'play' button. I tried different brands of headphones but it did not solve the problem. I believe this may be related to the issue of current leaking into the case (How can I avoid my MacBook Pro giving me minor shocks?). The power socket is close to the headphone socket.

The only workaround I could find was to switch to bluetooth headphones (which maybe is what Apple is pushing for!)

1
  1. Open the music app.
  2. Go to Music pulldown menu.
  3. Select Restrictions.
  4. Disable Music Options, Apple Music, iTunes Store, Shared Libraries
  5. Click OK.
  6. Close Apple Music.

Restrictions Deselect

This worked for me on MacOS Catalina v10.15.7, 2019 - MacBookPro.

1
  • The first three of those were already disabled by my administrator. I checked the final box, and closed Music.app, but it still re-opened after hitting the button on my headset. I also tried turning off "Sync Library" and that didn't help either. I'm on 10.15.7 also.
    – parzival
    Feb 4, 2021 at 20:09
1

Deleting all the songs from Music app has helped me to overcome this issue. I just opened the Music app, selected songs, right click, delete and sent to bin.

It's possible for me as I do not listen songs, I know for many of us this solution is not an option.

0

For those who are using Keyboard Maestro you can create a simple macro that will instantly close Apple Music when it starts. It is almost the same way as how noTunes works, but one app less.
You can find the macro source file here. enter image description here

-1

Disabling Handoff Feature

First, you will want to try disabling the Handoff feature. You will need to:

Go to Settings > General > Airplay and Handoff. Toggle Handoff to OFF.

Switching this feature off can aid in the removal of your iPhone’s memory that you had played music on your phone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .