I noticed that when I close to lid of my MacBookPro 2008 edition. My computer does not go to sleep. I also observed that this occurs when the Mac is plugged in. When I unplug, everything seems to be working fine. Does it have something to do with Lion? I already tried changing the energy settings in System Preferences.

3 Answers 3


Oddly Resetting my Sharing preferences did solve my problem. All I did is go into the System Preferences Settings. 1. Chose Sharing. 2. Uncheck everything that is checked. 3. Close System Preferences. 4. Open Systems preferences back up. 5. Go back into Sharing 6. Check everything you want checked 7. PROBLEM SOLVED !!! (For me at least) I have a 2008 MacbookPro running Max OS X 10.7.2


The culprit is the internet sharing checkbox. If you had it enabled, the computer will stay on when the lid is closed, but turn the display off. This is so that the bridge stays up. Uncheck Internet Sharing and your sleep mode should functions properly.


Try an SMC Reset.

The System Management Controller (SMC) is responsible for many low-level functions on Intel-based Macs. These functions include:

  • Responding to display lid opening and closing on portable Macs
  • [...]
  • Unfortunately resetting SMC and PRAM did not work for me but I did find a solution to my problem. Jan 18, 2012 at 4:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .