6

How do I resolve this? Error was encountered on a 2018 MacBook Air.

enter image description here

  • I encountered the same thing on 2018 MacBook Pro (13-inch, Four Thunderbolt 3 Ports) – LHM Nov 19 '19 at 14:45
2

First solution:

It is reported that this error occurs during the installation of macOS Catalina if the Internet connection is interrupted or disconnected.

Make sure that the Mac has an active wi-fi or ethernet connection and that the Internet works as expected, and then try to install macOS Catalina again.

Second solution

The Recovery Mode installer of Catalina appears to not be able to properly partition the drive.

Install High Sierra or earlier macOS from Recovery Mode and then upgrade to Catalina or install Catalina (or High Sierra) from a bootable drive.

| improve this answer | |
2

I have been pulling my hair out with the same problem over the past few days, and have isolated the PKDownloadError error 8 issue - I was able to solve this via 2 methods:

  1. use my iPhone's hotspot as the wifi for the update (note: this is slower AND may be very expensive depending on your cellphone plan)
  2. change the DNS settings on my home router to OpenDNS (https://use.opendns.com/), allowing me to use my home internet (faster & cheaper)
| improve this answer | |
  • Thank You, for pointing out OpenDNS, changing DNS solved the issue – Manee.O.H Apr 28 at 20:58
  • I have a good stable connection, the DNS issue was really the thing tripping it up. I must had tried installing over 30 times, by using a different DNS (google one), it got through without a hinge. – Frank May 20 at 6:40
1

I was having this error using a Catalina installer on a USB key I made with createinstallmedia. Using this method, the installer shouldn't have to download anything, so a 'download' error didn't make sense.

Purpose: Encrypting and clearing drive in order to return the computer to seller.

Prep work: After encrypting drive, I deleted the old APFS container with Terminal, then I formatted the drive as a single APFS volume named 'Macintosh HD'.

Installation: After beginning the installation, the bar would begin to fill with '3 minutes remaining'. Once it got to about 80%, it said '2 minutes remaining' and it would hold up. A minute or so sitting there and it would give the same error stated above. I retried this a few times.

Fix: I turned off WiFi (completely disconnected from Internet). After doing this, the installation completed as expected.

Suspicions:

The installer app I used was downloaded 3 weeks prior to using it. These do have a short 'expiration' period. Usually resetting the clock to be right after the original download time fixes that issue, but it did not fix it here. Still, communication with Apple's servers or an attempt to download an updated utility could have notified the installer of a discrepancy and forced an error.

| improve this answer | |
0

I faced the same error with a brand new installation, I don't know about your case. You can reboot your mac then hold the "option key". You will see a select box to select a wi-fi network after that the recovery by the internet will start. That way you can install a version before Catalina. In my case was Sierra. Then after the new installation, you can update to Catalina!

| improve this answer | |
0

For what it is worth, this had to have been a content filter issue for me. I have prepped 2 new Macs, a 2019 Air and a 2019 MBP, and got this error on both my wired and wireless networks.

I was able to plug the same devices on edge connections (read: less restrictive internet connections) and the install went through with no issue.

If I had time, I would try to see what resource was being blocked, but at least for now, I know what was causing the error and how to get past it.

Austin -Network Administrator @ a large 9-12 Educational Institution

| improve this answer | |
0

My co-worker and I encountered the same thing on our 2018 MacBook Pro (13-inch, Four Thunderbolt 3 Ports) computers.

It turns out that having Cisco AnyConnect installed on the computer interferes with the installation somehow. My coworker used the Cisco AnyConnect Uninstaller to remove the program, ran the installer again successfully, and then re-installed Cisco AnyConnect.

I found that I needed to restart my computer in Safe Mode (hold Shift key during restart) and then I was able to complete the download and install of Catalina.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .