2

Stupidly self-inflicted issue here.

For whatever reason, my initial upgrade to Catalina didn't go well. It could not be verified first time around. Restarted. Update not found. Restarted again and retried a number of times but still no luck.

Stupidly followed these instructions as I was getting desperate and thought they might apply to the standard Catalina installation. They did not (I should have noticed 'beta' in the URL.)

This had the effect of macOS Catalina no longer being available through Software Update. Only macOS Catalina Beta:

Software Update only showing beta available

I ran sudo softwareupdate --clear-catalog as instructed here, which removed macOS Catalina Beta, but now I'm apparently all up-to-date on Mojave.

Even attempting to download the Catalina installer through the App Store gives me this error message through Software Update:

Update not found

Is there any solution here? I'm getting the feeling my only solution here is an OS reinstall.

Thanks!

3

You don’t have to erase your current OS to make a new Catalina volume and install it cleanly.

Once you get the version you want installed, you can migrate over the data or not as you please.

This saves you from having to erase first to test the install / get ready to erase the old OS that’s stuck in beta land.

1

If just removing the Beta profile in System Settings does not work, try to unenroll from the Beta Program: https://beta.apple.com/sp/betaprogram/login_to_unenroll#macos.

This immediately resolved the problem for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .