3

Every time I want to use ", ', or ` I have to hit space to type a single character. In some apps, for example VS Code, this situation is worse where I cannot even type a single character. Here is a gif that shows what I mean:

https://i.sstatic.net/Jy4Mv.gif

So how can I disable this? I am using an external USB Keyboard with ANSI Layout. I am currently still on Mojave since I have to wait for updates on a few apps before switching to Catalina.

1 Answer 1

5

Go to System Preferences > Keyboard > Input Sources and get rid of the item called "US International PC". Instead use US or ABC.

(US International PC is a special layout where those characters are deadkeys for typing accent marks used is various European languages).

2
  • Thank you su much! I would never guess that the Input source would be the cause of this. Commented Oct 16, 2019 at 14:32
  • In macOS Ventura, the location ihas been changed to system settings > keyboard > text input > edit Commented Apr 12, 2023 at 18:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .