0

Version: 10.15 Beta (19A526h).

Behavior:

The window in the picture becomes unresponsive after this popup appears. I can't press "Restore Default" at all. I've restarted my computer, went in terminal and entered sudo softwareupdate --clear-catalog, and then went in the App Store to get the stable release of Catalina. Anyway, it doesn't help because it takes me to System Preferences again, where it becomes unresponsive.

Is there something else I can do to get the stable version of Catalina on my machine?

Update: Was able to use keyboard (tab / space / enter) to select "Restore Default", I enter my password when I'm prompted but then the window just closes and nothing changes. Have also tried the same thing with installing Catalina from Mac Store. After downloading ~6GB, it pops up ad says "Update Not Found: The requested version of macOS is not available."

enter image description here

0

It took multiple attempts to download the Catalina update. The last attempt gave an error, but somehow the install screen for Catalina showed up and I was able to perform the update. The issue with System Preferences seem to have been fixed.

  • What was the actual solution? Did you keep trying the screenshots you posted above? (Register for beta, restore defaults again, repeat?) – Mark McCorkle Oct 22 '19 at 12:31
  • IIRC Download Catalina from App Store, try to install from System Preferences, it only installed part way, but each time it got a little further Than before, eventually Catalina Install showed up at the dock. It worked after that – humanlikely Oct 22 '19 at 19:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .