8

I have an iphone XS, and have been using GBoard since I got the phone a year ago with no problem.

Recently I upgraded to ios 13, and I've noticed GBoard having issues ever since.

Frequently when I open an app, gboard does not appear, and instead the default english keyboard appears (I have gboard set as primary). When I click the change keyboard button, I have to cycle through all my keyboards multiple times before gboard actually shows up. The first few cycles, gboard will appear for a split second before crashing and going back to the default english keyboard again.

Previously, I had an iphone 7S, which had the exact same symptom. GBoard was working perfectly until I did an OS upgrade, and then it started crashing the exact same way. It gradually got worse with each OS upgrade until it became completely unusable.

3

The assumption you're making is that the problems you're having are related to the upgrade to iOS 13.

Now, while this assumption may be correct, it's also the case that around the same time iOS 13 was released, Google also updated Gboard to v 2.3.0 and, not long after, to 2.3.1. In other words, not only did the version of iOS change, but also the version of Gboard.

As a troubleshooting step it would be good to test the latest version of Gboard on an iPhone that's not running iOS 13. I do appreciate, however, that's not necessarily an option for you.

So, what I'd try is totally removing Gboard from your iPhone and then re-installing it from scratch.

Removing Gboard

  1. Open Settings
  2. Go to General > Keyboard > Keyboards
  3. At top right, tap Edit
  4. In the list tap on Remove next to Gboard

Re-installing Gboard

  1. Download Gboard from the App Store
  2. Configure Gboard as per your preferences (keyboard, full access, etc)

Now test to see if that's helped to alleviate the situation.

| improve this answer | |
3

Yes I had a similar issue: periodically Gboard keyboard would crash after a second or two (and iOS replacing it with standard keyboard). Not doing anything, simply clicking to write, wait 2 seconds and the screen would change with the standard keyboard. The first time I solved it like I deleted the Gboard app and reinstalled it & rebooted. But now I tried something else & worked: I went to Gboard app, and into the Keyboard Settings menu it has, and for starters disabled all its settings (they are blue radio buttons, put them off all). Then, whenever I would access keyboard, Gboard keybord woud pop up and stay up. So it would function. Then putting back just the settings I need: sliding writing and automatic correction. Works like a charm. Of course don't forget to be up to date with all your iPhone iOS version and GBoard app.

| improve this answer | |
  • Thanks a million, your solution helped! I really got used to GBoard and could use any other keyboard when I wanted to switch to something else. I guess there's some particular setting that leads to crashes. – Boykodev Jan 13 at 12:29
2

Go to Gboard's Keyboard Settings and disable "Share usage statistics". That worked like a charm for me. Gboard stopped crashing every time I edit a text. I am guessing there is a problem with that setting where it crashes the keyboard.

| improve this answer | |
  • oh snap, thanks for the tip, I'll; try it – Razor Storm Mar 7 at 1:23
2

If the other options don't work, try disabling Allow Full Access under Settings > General > Keyboard > Keyboards > Gboard.

This disables the Google Search feature, but stopped the crashes for me.

| improve this answer | |
  • So I reinstalled a bunch of times and it seems.... kinda stable now. I'll def try this if it breaks again. Thanks! – Razor Storm Mar 7 at 1:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .