3

I purchased a used MBP (without a hard drive). See model details/specs below. I am trying to install Mac OS X Snow Leopard (Version 10.6.3). I have successfully done this using the same process on two older MacBooks (A1151, A1181).

I searched the Ask Different postings and did not find what I was looking for. Many similar ones exist. But most folks with this issue have the original, still working HD to work with. Not me.

I also confirmed that my MBP is compatible with Snow Leopard. Compatibility list on Everymac.com

Here’s mine.

Apple MacBook Pro "Core i5" 2.4 15" Mid-2010 Specs
Identifiers: Mid-2010 15" - MC371LL/A - MacBookPro6,2 - A1286 - 2353*
Model: A1286

Specs listed on everymac

I purchased a retail copy of Snow Leopard. I have it on DVD and I have imaged it to a USB stick with Disk Utility to make for easier installations. Then I installed a hard drive into the MBP, held down the Option/Alt key to boot from the USB drive. It then, as expected, shows me the only option which is to boot the Mac OS X Install DVD. As soon as I hit Enter, the screen changes to the Apple logo screen (with nothing else, no progress meter, no spinner). And there it stays.

I’ve left it untouched overnight. I’ve tried using the DVD instead of USB. I’ve reset the NVRAM/PRAM more times than I can count. I’ve tried using different hard drives. Different Memory. Swapped the sticks. Used only one slot. I tried installing Leopard (10.5 via CPU Drop-in DVD). Nothing seems to let it get past this screen. I don’t want to give up on it since it’s such a lovely machine.

Here’s a small google photos album for reference.

I’ve used the same technique to successfully install Snow Leopard on two older MacBooks (mentioned above). I’ve also booted Ubuntu Linux on USB successfully. So I know the machine is functional.

Any ideas? What else can I try?

  • Some versions of some macOS installers apparently come with a certificate that expires and can therefore not be installted now unless you backdate the Mac's clock. So try to set the date on your Mac to for instance some time in 2011 and see if that does the trick – Lars A. Gundersen Oct 19 '19 at 16:06
  • Just saw this comment. That sounds like a good idea. But how can you set the date with an empty hard drive and just the install DVD/USB? All I could ever get to was just the Apple logo. I got it to work using a different method, but I'd like to test out your suggestion. Just not sure how to get to a screen (or command line) to do so. Let me know and I'll give it a shot. Thanks! – superwattage64 Oct 25 '19 at 3:36
  • If you cannot get to the recovery partition by holding doen CMD-R upon boot and from there the Terminal, the only option would be too boot the Mac from a bootable USB-stick or similar, containing a full system that allows log-in. – Lars A. Gundersen Oct 26 '19 at 7:44
0

Your screenshots show you are not connected to a network. Perhaps if you connect to WiFi or an Ethernet dongle Internet Recovery would kick in.

Also if you can connect to another Mac with a cable you could clone that Mac’s OS over to your drive. You could also remove the drive and use a dock to clone from a working machine. After you clone you could potentially be able to erase the disk and reinstall the OS using the recovery utility.

  • I tried (but didn't photo) using wi-fi as well. Same result, unfortunately. But I do have good news that I got the problem solved. It wasn't pretty. And I think it uses a variation of cloning like you were mentioning. Will post a follow-up shortly with details. I'd like to know more about connecting to a working Mac with a cable like you suggested. Got any links on that? That probably would have been much easier that what I ended up doing. – superwattage64 Oct 25 '19 at 3:01
0

Have you considered doing away with Snow Leopard entirely? I had good experience using this patcher tool: http://dosdude1.com/software.html to install High Sierra on your generation Macbook (officially unsupported for that model, but performing surprisingly well).

  • I tried using Leopard (10.5), which is the only other OS install disc I had available. It didn't work either. According to EveryMac, Snow Leopard is the OS it shipped with originally. I will look into the patcher tool you suggested. I eventually got High Sierra installed. Will post a follow-up shortly with the write-up. – superwattage64 Oct 25 '19 at 2:58
  • Well, just pull the ESD file off the App Store using a VMware or friend's Mac. Way I see it, you're entitled to it since you do own a paid-for macOS, which if you had been able to install and update it all the way through, would become a modern-release macOS. Anyway, I'll leave the legality of obtaining it to you, but I should really like you try the patcher tool, I'm still kinda amazed about it :) – Dan Oct 30 '19 at 3:50
0

So I got it working. It was ugly, not how I envisioned, and I'm still not delighted. But it works. Let me explain.

I mentioned earlier that I successfully used the same method to install Snow Leopard on two older MacBooks. Well that turned out to be the key. You gotta have access to a working installation of the OS. At least I had to in my case. My coworker suggested (as a test) transplanting the hard drive from one of the other MacBooks into the one that was giving me trouble.

This ended up working. But there are some caveats and I had to jump through a few hoops. After moving the "good" drive to the target MBP, it initially froze at the same spot. But the difference was that now I had a recovery partition. At first, I tried holding Shift and booting. That did nothing.

After that, I tried booting into Recovery Mode with Cmd + R. Instead of starting the recovery wizard (with Disk Utility), the screen immediately changed to showing a globe (not the Apple logo). And it let me connect to the internet. This was new. I was hopeful! It was the Recovery over Internet wizard!

I connected to my wi-fi and let it do its thing. It took about a half-hour. When it rebooted, I could see that it had downloaded and was booting up High Sierra (which I think is the max OS this MBP will support).

But there was a catch. The password I had setup/used on the previous laptop would not work. I guess because the system recognized that it was in a different machine. Maybe the password is paired to the older hardware set(?) No idea.

Well, I found an article that walked me through resetting the password. That worked flawlessly and it's where the story ends.

So I got it to 'work', but it's still not the clean solution I was looking for. I still don't know why I could not start from scratch with a new, empty hard drive installed. I want to test out the suggestions from Lars, Dan, and user711393. But for now, it's working and I'm happy.

I hope this helps someone else out who encounters a finicky MBP like mine.

List of helpful sites I used at various stages

Again, it's not perfect, but I consider this case closed for now. Thank you AskDifferent community!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .