2

Since upgrading to macOS 10.15, the mail app is no longer able to open a message by its URL.

For instance, the URL message:%3CCAEkAa-anCn=ZE21kpFw-oKaXEVsGE0SuuNtyUT8qyZndoPMuaQ@mail.gmail.com%3E which launched the corresponding message is now causing Mail app to show the following message:

The operation couldn’t be completed. (MCMailErrorDomain error 1030.)

Mail was unable to open the URL “message:%3CCAEkAa-anCn=ZE21kpFw-oKaXEVsGE0SuuNtyUT8qyZndoPMuaQ@mail.gmail.com%3E”.

1 Answer 1

2

According to your error message it looks like a Mail plugin incompatibility. One or more plugins are not fully compatible with macOS 10.15 Catalina, yet. Did you install GPGMail.mailbundle or additional mail plugins? If so,

  1. Completely shut down Mail.app
  2. Navigate to ~/Library/Mail/Bundles
  3. Move GPGMail.mailbundle to your desktop
  4. Restart Mail and try again
4
  • Thank you for your reply. The plugin which caused the problem is SmallCubed MailSuite, not GPG.
    – user49204
    Commented Oct 13, 2019 at 19:24
  • Side question, this link the same error on 10.14.5. I have no plugins installed. What type of Links work on Mojave?
    – anki
    Commented Oct 13, 2019 at 21:39
  • @ankii: The original question is related to MacOS Catalina 10.15. What link are you referring to?
    – user136834
    Commented Oct 14, 2019 at 10:04
  • message:%3CCAEkAa-anCn=ZE21kpFw-oKaXEVsGE0SuuNtyUT8qyZndoPMuaQ@mail.gmail.com%3E should open a mail in 10.14 if I am not wrong? After getting the permission of opening mail, it shows the same error as in the question.
    – anki
    Commented Oct 14, 2019 at 10:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .