1

I have a problem with my MacBook Pro 2018. There no haptic feedback on the touchpad. It worked with Catalina well, but only for a few days. The touchpad works very well with all gestures. There is only no vibration when I klick anything. What I did:

  • restart the MacBook
  • NVRAM reset
  • SMC reset
  • I set the MacBook to default configuration and don't logged in with my Apple ID.

Anybody here who has another idea what to do?

2
  • I just upgraded to catalina last night. Last night I had haptic feed back. Today I don't. Feb 1, 2020 at 1:23
  • 1
    On my MacBook, the logic board was defective and had to be replaced at an authorized Apple dealer. Among other things, the keyboard, the battery, the touch bar and the top of the case had to be replaced. Try to log in with a newly created user account and see if the error still occurs. This is what Apple Service tries. Feb 2, 2020 at 9:16

1 Answer 1

1

For my 2015 MBP, this happened immediately after upgrading to Catalina.

My MBP was no longer under warranty so going to apple wasn't an option.

What worked for me was:

"It just started working again a few days later"

Most of the advice I found elsewhere, and tried, was:

  • pram reset
  • power off and leave it off for a while
  • check for battery swelling
    • my battery was swollen a year ago, when it was under warranty, and Apple replaced a lot of things
  • send it in under warranty

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .