1

Before I upgraded, I used Command K to connect an SMB share. I had upgraded macOS from Mojave to Catalina yesterday. When I use Command K to connect that SMB share, it doesn’t work.

Does the new macOS disable SMB? Help me please, it has decreasesed my work efficiency.

  • What is the kind of SMB share? A NAS, a Windows server, a Mac server? Please elaborate a bit (NAS model, Windows version etc.). – Gummibando Oct 12 '19 at 7:41
  • 3
    Does any of the info here help? – Monomeeth Oct 12 '19 at 9:50
1

I had the same problem and solved it in a strange way, As we are all aware Mac user has actually 2 names: one is the username (the profile name if i may) and the Display name.

Prior to Catalina , when authenticating with an SMB share from a Windows computer , I was using the display name (although it is a full name with a space - strange for the traditional windows user...) and everything was cool.

In Catalina , I found out I can only use the username, windows cannot authenticate with the display name.

of course , before I got to this point I have checked/enabled SMBv2, created the NetBios file in the MAC and all the other hints I could find, which obviously did not do the trick for me.

hope this helps

1

SMB is not disabled, but netbios name resolution is. See this answer to test if you just need to set up DNS or reactivate netbios.

You can always connect by IP address to test if it’s name resolution before changing your preference files or altering the system configuration.

0

I have been struggling connecting to my QNAP NAS via SMB for a while now too (from Catalina 10.15). First I switched to afp protocol which seemed to work better, but I hate workarounds instead of solutions. In the end, this seems to have fixed the problem for me: delete the Finder preferences.

Use the Finder menu to go to a folder (Shift Command G) and copy this path in: ~/Library/Preferences/ Then locate the file: com.apple.finder.plist and Delete it (move to Trashcan).

I always empty my trash too, not sure if that's important here.

SMB is lightning fast now, faster than it's ever been.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .