5

I understand this question has been asked before, but my situation is a bit different. I have done the usual, I've tried

diskutil cs list

then

diskutil apfs resizeContainer disk0s2 370GiB

(from an original volume size of 402GiB). It gave me the error

Error: -69521: Your APFS Container resize request is below the APFS-system-imposed minimal container size (perhaps caused by APFS Snapshot usage by Time Machine),

which was interesting because I have never used Time Machine and I erased all 'snapshots', not that there were any, on my disk already using

tmutil thinlocalsnapshots / 9999999999999999.

Why is it that I keep getting this error? What am I missing? I want to use the free space from resizing on my Boot Camp partition to give it some breathing space, it's almost full. I'll be doing that using partition wizard later, but before I even think about doing that, I have to solve the problem here first.

I'm on Catalina build 19A582a for those wondering, on an Early 2015 MacBook Pro 13".

1
  • To increase the size of the boot camp partition, you would have to "forward" expand (which means: the first block of the BC partition gets a lower disk block number and its overall size will be increased in a second step) it, assuming the BC partition is the last one on the disk. With on-board tools this will fail. – klanomath Oct 11 '19 at 13:49
5

Check to see if you have more snapshots...

tmutil listlocalsnapshots /

In my case, thinlocalsnapshots didn't do the job totally. I had additionally run

tmutil deletelocalsnapshots /

After which there were no more with listlocalsnapshots and I was able to resize the container.

2
  • I tried your suggestion and now I get - Snapshots for volume group containing disk /: - and nothing is displayed, and then when I try deletelocalsnapshots it shows me Failed to delete all Time Machine local snapshots for volume group containing disk '/', so I'm guessing this is a bug. I'll report it anyways as I think it's something they should fix or at least create a workaround for. – Ivanthehackerful Oct 25 '19 at 21:07
  • I had to run sudo tmutil listlocalsnapshots and then go through each snapshot listed and run sudo tmutil deletelocalsnapshots <snapshot-date-here> and then the resizing worked! thanks! – maxfowler Dec 13 '20 at 18:50
0

I managed to resize. Firstly it should be noted that Mac now has support for resizing, but not in the old 'drag the pie chart' way it used to be. To resize, select the APFS container, and in the bottom right where the size is, change the value to your preferred size. This will result in the container being split, with a new disk containing the freed up space. How to give this space back to the disk as a whole, I'm not sure, but this was good enough for me.

The terminal command for doing this is:

sudo diskutil apfs resizeContainer disk0s2 750g jhfs+ Extra 250g where disk0s2 is the target container, 750g and 250g are the size of the existing and new disk respectively, jhfs+ is the format of the new disk, and Extra means "create a disk of this size".

The total of the existing and new disks should add to be the size of the disk before being resized.

sudo diskutil apfs resizeContainer disk0s2 750g jhfs+ Media 0b automatically determines this size using the Media 0b extension, so this isn't necessary if you just want to resize.

For more help on this visit https://www.macobserver.com/tips/deep-dive/resize-your-apfs-container/, credit goes to the author.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .