2

With Mojave, I use to open multiple pdf at once with the old Preview9.0.app (version of Sierra)

It doesn't work anymore with Catalina because of a conflict between Preview9.0.app and the new PDFkit framework.

Is there any way to embed the old PDFkit framework in Preview9.0.app ? Or redirect PDFkit calls to the old one ?

9
  • Is it a 32-bit app? Oct 10, 2019 at 12:36
  • 1
    No, Preview 9.0 works normally except for pdf just because of PDFkit I guess.
    – Praleonea
    Oct 10, 2019 at 12:39
  • Not without writing your own application. Why do you need Sierra's Preview in Mojave? Also, what exact errors are you getting in Catalina?
    – benwiggy
    Oct 10, 2019 at 12:47
  • Preview9.0 crashes while opening any pdf. I need it because it can open very multiple pdf at once without separate tabs and search across very fastly. Application Specific Information: *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[PVPDFView setEnablePageShadows:]: unrecognized selector sent to instance 0x7feaa97a1e60' terminating with uncaught exception of type NSException abort() called
    – Praleonea
    Oct 10, 2019 at 12:56
  • You can still open multiple PDFs in the same window, if you want.
    – benwiggy
    Oct 10, 2019 at 13:01

2 Answers 2

1

I'm sure it was possible ! Cormiertyshawn895 dit it ! Thanks to him ! https://github.com/cormiertyshawn895/Retroactive/issues/1

2
-1

Preview, like many other Apple-bundled apps, is designed to use the Operating System's frameworks. There is no practical way that the application can be reconfigured to use a separately supplied framework without having the source code and altering the application before compiling an altered version.

It's also worth mentioning that PDFKit in Sierra has many critical bugs!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .