1

http://osxdaily.com/2017/03/01/disable-mac-camera-completely/

Following this advice, at one point I have used cmd lines to either disable or deleted the components...(such an idiot)

While sudo chmod a+r /System/Library/Frameworks/CoreMediaIO.framework/Versions/A/Resources/VDC.plugin/Contents/MacOS/VDC still works, I get "No such file or directory" when I do next four commands to restore webcam.

1)sudo chmod a+r /System/Library/PrivateFrameworks/CoreMediaIOServicesPrivate.framework/Versions/A/Resources/AVC.plugin/Contents/MacOS/AVC

2) sudo chmod a+r /System/Library/QuickTime/QuickTimeUSBVDCDigitizer.component/Contents/MacOS/QuickTimeUSBVDCDigitizer

3)sudo chmod a+r /Library/CoreMediaIO/Plug-Ins/DAL/AppleCamera.plugin/Contents/MacOS/AppleCamera

4)sudo chmod a+r /Library/CoreMediaIO/Plug-Ins/FCP-DAL/AppleCamera.plugin/Contents/MacOS/AppleCamera

I don't know how to fix this issue. Can anyone enlighten how to tackle this issue. Thank you in advance.

  • If the "reversal" steps in the article don't work, I'd backup the computer, then reinstall a new macOS, either from an installer (if you have one), or the Command-R Recovery function. More on Command-R here: support.apple.com/en-us/HT201314 and support.apple.com/en-us/HT204904 – David supports Monica Oct 10 at 3:39
  • Thanks David, used Command-R went into Recovery mode used disk function to "erase" the mount and re-used the MacOS Catalina that was downloaded to reinstall a new macOS...even though Imessage video phone call works now, still get message "No Video. FaceTime has not received any video from the connected camera. Restarting your computer may fix this issue" msg. Tried installing camera app from app-store...other apps also shows same blacken screen...any other suggestion? – Min-Hong Lee Oct 10 at 18:20
  • You're welcome, sorry it didn't work. The only other things I can suggest are 1) downloading FaceTime again, and 2) setting up a new (test) user account to see if FT works in that environment, as there might be something awry in your own user account. – David supports Monica Oct 10 at 22:08

You must log in to answer this question.

Browse other questions tagged .