1

I just updated to macOS Catalina.

Looks like I can't type a word I don't know the meaning of into spotlight and get its dictionary definition anymore, even though in System Preferences > Spotlight "Definition" is checked.

How re-enable the functionality so that spotlight can be used like a dictionary?

1

It seems like the default dictionary changed during the upgrade to Catalina. I had to go into the Dictionary app settings and select New Oxford American Dictionary (for American English).

  • My previous dictionary was at the bottom of the list. I dragged the already-checked Oxford Dictionary of English up to the top, now it seems to work. – theonlygusti Oct 14 at 14:33
-1

You must check the box "Allow spotlight suggestions in lookup". It's on the same panel as where you checked "Definitions"

If that doesn't get it, check the box for applications and be sure you have a dictionary in your applications folder.

When I do a spotlight search on my iMac of the word obtuse, for example, it gives me the definition from my dictionary app. So some way it actually looks inside or uses my dictionary app.

  • "Allow spotlight suggestions in lookup" is checked. Dictionary.app is in /Applications. – theonlygusti Oct 9 at 18:20
-1
  1. Open System preferences
  2. Click/ Open Spotlight
  3. In the Search Results listing tab, scroll down and deselect the "Spotlight Suggestions" checkbox.
  4. Deselect the “Allow Spotlight Suggestions in Look Up” checkbox
  5. Now the default Dictionary will be used, make sure you have the Dictionary app in the Applications folder. Also, in the Dictionary preferences, select your language, if not already.
  6. You may have to restart your application (e.g. Pages) for the Lookup to default to Dictionary.

Happy Lookup!

  • I don't think this answers the question. I think you may have misunderstood the question? Anyway, carrying out these steps didn't help. – theonlygusti Oct 14 at 14:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .