5

I've just clean installed macOS Catalina and the usual way of activating auto complete does not work for me. I use the default shell zsh:

1 Type in terminal nano ~/.inputrc
2 Paste the following on separate lines

set completion-ignore-case on
set show-all-if-ambiguous on
TAB: menu-complete

3 Hit control+O to save changes to .inputrc followed by control+X to exit nano
4 Open a new Terminal window or tab to open a new session with autocomplete enabled

What am I missing?

1
  • If you’re not using zsh - just edit this to show precisely what shell you use.
    – bmike
    Nov 17, 2019 at 23:52

2 Answers 2

3

If you have done a fresh install then you need to be aware that the default shell has changed to zsh which as I understand it doesn't read .inputrc.

So either change your default shell back in System Preferences -> Users & Groups or use .zshrc instead for your configurations

3
  • Do you by any change got the correct tut for zsh? But this is already good input!
    – David Seek
    Oct 9, 2019 at 15:57
  • 1
    Sorry, I am new to zsh as well and since I upgraded rather than did a fresh install auto completion just works for me. Oct 9, 2019 at 16:35
  • Your idea of moving back to default shell is obviously an option to fix this for now. But I'd like to stay with zsh. Even tho I don't understand the differences, whoever made the decision to move, does. Appreciate your input!
    – David Seek
    Oct 9, 2019 at 18:05
2

After new installation just run this command in your zsh terminal:

autoload -Uz compinit && compinit
1
  • This only seems to work for one session. After I restarted by computer I needed to re-run this command. Is there another solution that reminds this setting? Apr 26 at 14:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .