1

This question already has an answer here:

I tried updating to Catalina, but it got stuck on not having enough disk space. It says I have to quit the installer, select a start disk and boot from that, but my system's drive is not in the list of drives that I can select...

So, instead, I started the Terminal, went to the drive through that and I started deleting things. But every time I run df I don't see a change in the amount of disk space. Between reboot changes are persisted though, even creation of new files.

I then installed Mojave on an external drive and mounted the internal drive, it shows up as 52GB free (vs 12GB from df). But when I run df I still see only 12GB free.

I figure there is some sort of place where deleted files are getting moved to in order to provide me with some fancy restore magic for when the installation is done. Where is this magical place and how do I delete files from there so that I can continue the installation?

The answers here don't address my issue because I already know what was eating my disk space.

marked as duplicate by fsb, LH16, nohillside macos Oct 12 at 14:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • macOS Catalina update failing due to low disk space and it's linked questions. – ankii Oct 9 at 12:32
  • @ankii thanks, but the answer says " To turn purgable storage to free storage disable iCloud and Time Machine backups among other techniques." Which, as far as I know, doesn't apply to my case, because I can't boot into the original installation anymore. – Mosselman Oct 9 at 13:11
  • @fsb I already know what was eating my disk space, I deleted it in the terminal with rm, but the problem is that the space does not become available after deleting. – Mosselman Oct 9 at 13:13
  • apple.stackexchange.com/a/106576/88313 maybe? – fsb Oct 9 at 13:39
  • @fsb sadly there is nothing there. I deleted with rm, which normally wouldn't trash things. – Mosselman Oct 9 at 13:55
0

So, after a few hours of working on this (mainly making rsync backups) I have it working.

What was crucial was creating a new macos installation and mounting the old disk on that. I didn't really delete any files and df kept showing the same amount of free space, but after a reboot to the original disk the install passed.

I think it has something to do with things being purged by the new macos install (Mojave on an external drive).

Not the answer you're looking for? Browse other questions tagged .