7

So I took the plung and upgraded my Late 2013 Macbook pro from Mojave to Catalina. Everything else "seemed" okay apart from the fact that I had no wifi. The icon was greyed out. I tried all the usual advice, SMC and NVPRAM/PRAM resets. I even deleted the Network plist file but still the wifi icon was greyed out and from the System Information App all I had under Network -> Wi-Fi was:

  Software Versions:
  CoreWLAN: 13.0 (null)
  CoreWLANKit:  13.0 (null)
  Menu Extra:   13.0 (null)
  System Information:   12.0 (null
  IO80211 Family:   12.0 (null)
  Diagnostics:  1.0 (null)
  AirPort Utility:

In the Network app, the Wifi interface isn't listed when I tried to manually create the wifi entry. In the end I was ready to take my Macbook pro for repairs as I believed that my wifi interface was fried. Then I decided to downgrade back to Mojave and it worked perfectly.

I tried the upgrade again up to Catalina and the wifi problem showed up again. So now I'm back on Mojave. The supprise for me is according to Apple model of Macbook pro is supported by Catalina so I'm not sure whats going on.

  • I have the exact same problem on a 2015 MBP 13"... – Giovanni Caporaletti Oct 9 '19 at 18:04
  • I asked here discussions.apple.com/thread/250720965 – Giovanni Caporaletti Oct 9 '19 at 18:19
  • I have same issue. Anyone find the solution? – Bhavesh Kumbhani Oct 11 '19 at 6:28
  • Facing the same issue also with a Late 2013 MBP 13" – cozeJ4 Oct 11 '19 at 10:36
  • @GiovanniCaporaletti have you made any progress with your issue? I'm still back on Mojave as a result. It was such a pain getting my machine back up to scratch wouldn't want to risk is again. – Napoleon Oct 16 '19 at 15:37
4

I had the same issue. Updated to catalina overnight and in the morning wifi was not working. I reinstalled catalina from Recovery again. Now wifi is working even though System Information App still shows (null) for Network -> Wifi entries

3

So thanks to Giovanni Caporaletti for posting and referencing this issues on the apple communities forum. I've as at today been able to update to Catalina and have wifi working. The solution can be found here

but to prevent it being lost for whatever reason I'll repost it below:

  • Download the modified files (thanks Alex!) and unzip > you get a folder named WiFi_kexts.
  • Boot into Recovery Mode: restart your computer while pressing and holding cmd+R
  • Open Utilities > Terminal via Menu Bar.
  • Type csrutil disable and hit return
  • Type reboot and hit return > computer reboots normally
  • Open Utilities > Terminal and enter cd and hit the space bar (don't hit return)
  • Drag the folder WiFi_kexts onto the Terminal window and hit return.
  • In Terminal, enter sudo mount -uw / and hit return, then enter your user password and hit return.
  • Enter sudo cp -r IO80211Family.kext /System/Library/Extensions/ and hit return
  • Enter sudo cp -r IO80211FamilyV2.kext /System/Library/Extensions/ and hit return
  • Right-click on Kext Utility in the folder WiFi_kexts and choose open, click open in the following dialog, authenticate with your password
  • Wait for Kext Utility to complete – this took maybe two minutes on my setup, and I got an error message in the end, as well as "All done"
  • Reboot your computer and enjoy Wi-Fi in Catalina If you want to turn on SIP again you can boot into recovery mode again and enter csrutil enable (hit return) reboot (hit return)

In summary I had to get the Wi-Fi kexts from Mojave, copy it to /System/Library/Extensions and then run the Kext Utility to do its thing after which I had my Wi-Fi back.

  • So with the recent upgrade to Catalina 10.15.2, I lost my Wi-Fi interface again and had to repeat the above steps to get it back. I don't know why Apple have decided to remove kexts from Catalina. – Napoleon Dec 17 '19 at 20:37
  • It's like a magic. It worked on macbook pro 2015 mid – Masum Apr 14 '20 at 15:19
  • @Napoleon I think the download link is no longer active. Could you please fix that? You're my only hope...Apple let me down big time. What a disappointment. – Jonathan Komar May 10 '20 at 14:27
  • @JonathanKomar the link is working fine for me. I've just downloaded the file again. If you're still having problems I don't mind emailing it to you. – Napoleon May 11 '20 at 20:37
  • It works on my macbook pro 2015 mid. i am totally surprised – Masum Jul 2 '20 at 18:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .