After upgrading to Catalina OSX 10.15 Easy Document Creator can no longer connect to the remote scanner. It shows up within settings and can be addressed directly but not over the EDC software anymore.

The error reads:

"Scanner device is not responding. Please check that it is turned on and connected to computer".

enter image description here Easy Printer Manager though shows the printer and its toner level etc.

Is there any fix for this? I know that Scan Assistent is 32 bit but that software was not needed anymore and OSX did not complain about EDC so in theory it should work.

In Samsung Easy Printer Manager also if I try to change the settings I get "Current input language cannot be accepted for device. Please change input language"

2 Answers 2


That is because Easy Document Creator uses several apps underneath and not all are 64-bit, as required by Catalina.

One of them is Select Scanner.app (in /Applications/Samsung/Samsung Easy Document Creator.app/Contents/Resources/Select Scanner.app), which is 32-bit for Intel and PowerPC (!).

The other one, with the same problem, is ICCUpdater.

There's nothing you can do; only bug HP to publish updated version.

Meanwhile, to be able to scan at all, use Image Capture or Preview (File, Import...). Just make sure that the scanned file is OK, the Apple drivers seem to be broken too; for example, I cannot scan in color into PDF, the resulting PDF is broken (Samsung M2070w). B/W PDF is fine, so is color JPG.


Re-create Bluetooth plist file on Mac

  1. Open Finder on Mac. Next, Go > Go to Folder > type “/Library/Preferences/” and Open.
  2. Find, com.apple.Bluetooth.plist file and Delete it.

enter image description here

  1. Now, Reboot your Mac to refresh Bluetooth settings.

Above mentioned solutions have worked 99% of the case.

Let me know how it goes for you.

  • Why Bluetooth? The printer/scanner is connected via WiFi.
    – merlin
    Oct 9, 2019 at 16:12
  • Have you tried it? It will not impact anything. Try and see it. Previously it was working and after the update it is not working, isn't it ?
    – Udhy
    Oct 9, 2019 at 16:14
  • No, there is no such file in existence. Just those: com.apple.driver.AppleBluetoothMultitouch.trackpad.plist com.apple.Bluetooth.133E3777-20D1-5B7E-BC1C-FFCEC5F80E85.plist com.apple.Bluetooth.CE17D42D-E98F-52A3-9260-D8E0139918C0.plist com.apple.Bluetooth.C175C084-1410-5A70-977E-CA1F718CB797.plist com.apple.BluetoothFileExchange.plist com.apple.driver.AppleBluetoothMultitouch.mouse.plist
    – merlin
    Oct 9, 2019 at 16:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .