2

This guide https://apple.stackexchange.com/a/295805/156133 is working fine on High Sierra. On Catalina installed with dosdude1 patcher (http://dosdude1.com/catalina/) I couldn't make it through, especially the thermal improvement.

I couldn't reload the AMDRadeonX3000.kext with sudo kextload /System/Library/Extensions-off/AMDRadeonX3000.kext . I've got this error:

/System/Library/Extensions-off/AMDRadeonX3000.kext failed to load - (libkern/kext) link error; check the system/kernel logs for errors or try kextutil(8).

I couldn't either create the sudo nano /force-iGPU-boot.sh, the permission being write only.

Does anyone have a solution how to run a broken GPU late 2011 on Catalina?

1

I'm having the same issue trying to load the AMDRadeonX3000.kext after boot.

I was able to create the force-iGPU-boot script though, by mounting the Catalina system disk as R/W in terminal:

sudo mount -uw /
  • this worked for me too, but it seems that the script disappeared from /root ? – aroom Oct 9 at 14:21
0

Not an answer, but perhaps more info for someone who can solve. Having the same issue. The system will boot with DosDude1's patch, but the AMD GPU is now being powered unfortunately. Event with the kext available at boot, this is all that gets loaded:

com.apple.kext.AMDLegacySupport (1.6.6)
com.apple.kext.AMD6000Controller (1.6.6)
com.apple.kext.AMDSupport (1.6.6)
com.apple.kext.AMDLegacyFramebuffer (1.6.6)

Using kextutil -v 6 /System/Library/Extensions-off/AMDRadeonX3000.kext , it cites numerous malformed headers, ultimately failing to link and load. Anxious to find a solution since booting is now a gamble. This explains why I couldn't boot even with the kext deleted.

New contributor
Sannhet is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .