7

I updated to Catalina today and now I cannot connect to my network drive via SMB.

I've tried:

  • using the ip-address, server name
  • the method of creating a nsmb.conf file

Regardless, all I get is an error message stating 'There was a problem connecting to server "name".'

I know the network drive is fine as I can still access the it from my phone and Windows 10.

Any ideas how else I might try to resolve this in macOS?

  • Creating the /etc/nsmb.conf didn't work for me either. But it is on the right track. On Mojave there is a netbiosd process running; on Catalina (10.15.1) there isn't. – Charles Hill Nov 2 '19 at 15:22
  • What is the kind of network drive? – Gummibando Jan 9 at 14:49
4

I was able to resolve this (temporarily) by restarting my Mac. I later discovered that I could restart the Finder to resolve it. Apparently the Finder app is responsible for network connections for other applications too.

While this does not prevent the reoccurrence, restarting Finder is a minor inconvenience. Hopefully this is a bug that Apple will resolve.

How to Relaunch the Finder

  • Hold ⌥ while right-clicking on the Finder dock icon → Relaunch
  • Open  Menu → Force Quit → Finder -> Relaunch
| improve this answer | |
  • How do you restart Finder? – AlxVallejo Apr 13 at 18:56
  •  Menu → Force Quit → Finder. – Henrik Apr 14 at 5:47
  • 1
    While holding ⌥, right-click on the Finder icon in the dock then click "Relaunch". – phip Apr 21 at 19:08
  • That's a nice tip, and super quick. I added both methods to the answer. – Henrik Apr 22 at 11:15
2

I ran into the same issue. Some SMB servers use NetBIOS and NetBIOS is disabled by default in MacOS 10.15 (Catalina).

https://medium.com/@gobinathm/how-to-access-smb-printer-shares-in-macos-catalina-10-15-17ea91d2c10b is a blog post that talks about it and lists the following steps to fix it.

By default, Apple has disabled NetBIOS in MacOS 10.5 to speed up SMB operations like mounting, browsing & connecting to an SMB share. If your own an SMB Printer/file server from the Past (i.e., Legacy or OLD) that requires NetBIOS to connect, then these devices won’t connect by default in Catalina like the prior version of MacOS.

In Order access these legacy SMB systems, you need to follow the below steps.

  • Check if your system has/etc/nsmb.conf file. If one does not exist then doing the following. touch /etc/nsmb.conf to create the file.
  • Edit this file in your favorite editor & ensure the following lines are present in the file
[default]
port445=both

Alternative, you can execute the below comments in your terminal.

echo “[default]” | sudo tee -a /etc/nsmb.conf 
echo “port445=both” | sudo tee -a /etc/nsmb.conf

Disable NetBIOS Simple delete the /etc/nsmb.conf

| improve this answer | |
  • I had already tried this method... but didn't work for me. Any other methods? – victoriajpn Oct 10 '19 at 6:19
  • The Medium article is behind a paywall for me, not a great source! – user95215 Feb 28 at 15:20
1

The method mentioned in https://medium.com/@gobinathm/how-to-access-smb-printer-shares-in-macos-catalina-10-15-17ea91d2c10b is a blog post that talks about it and lists the following steps to fix it. Should work. if this doesn't then there is some valid reason.

I'm the original author of that medium post & have seen one failure point till now. I.e., When you have SMB network Drive (or) Printer connect & you disconnect that network. Later when you try to connect it will give an error stating unable to connect. What you need to do here is manually reconnect to that server then only it will work.

| improve this answer | |
  • This didn't work for me. How do you know that this will enable NetBIOS? – JannieT Dec 16 '19 at 18:38
0

I too had (still have) the same problem and couldn't find any solutions in the net that would work. I also could not find any OSX Catalina documentation. However, I was able to find a (hopefully temporary) workaround.

This seems to be an authentication issue, and by disabling authentication requirements from my NAS folders, and selecting "Guest" as the mode of access, I was able to gain read/write access back to my NAS directories.

Hopefully, a better fix fill come along, at least one that won't require me to replace my NAS.

| improve this answer | |
0

I had the same problem and solved it in a strange way, As we are all aware Mac user has actually 2 names: one is the username (the profile name if i may) and the Display name.

Prior to Catalina , when authenticating with an SMB share from a Windows computer , I was using the display name (although it is a full name with a space) and everything was cool.

In Catalina , I found out I can only use the username, windows cannot authenticate with the display name.

of course , before I got to this point I have checked/enabled SMBv2, created the NetBios file in the MAC and all the other hints I could find, which obviously did not do the trick for me.

hope this helps

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .