I'm extremely worried about my MacBook. I tried updating to the official release of macOS Catalina a few hours ago but instantly hit a problem. I have not installed any beta releases beforehand.

I downloaded the updated and selected my drive as the install location. After a few minutes of the update seeming to go as normal, I was thrown a screen which said something like "macOS could not be updated on your Mac, there is not enough free space". It gave me the option to restart so I did that, hoping that I'd be able to log in and clear some more space for the install.

However, I restarted, entered my password then it seemed like the update instantly resumed. A few minutes later, the same error popped up so I pressed restart once more and the same cycle happened again.

Frustrated, I tried the obvious booting into recovery mode and selecting my main drive as the startup disk but whilst I was able to enter recovery mode, I wasn't able to select the disk - it didn't appear. I also tried booting into safe mode with no success.

I have done a lot of googling and most guides say something like "restart, log in and free up some space". The issue is, I can't log in. When I try to, it chucks me back into the update and the process repeats.

I would greatly appreciate it if someone could help me out - this issue is really concerning as I'm currently unable to use my MacBook and really need it for my studies.

  • 1
    Possible duplicate of Catalina Update Fail Purgeable Storage
    – lcharbon
    Commented Oct 9, 2019 at 19:59
  • I'm not sure; it's close to a duplicate, but since the methodology in which free space needs to be freed is different, I'm going to skip it for now.
    – JMY1000
    Commented Oct 9, 2019 at 21:34
  • And we were supposed to get rid of this type of problems by going out of the Microsoft ecosystem ... Commented May 24, 2020 at 8:16

6 Answers 6


I was facing the same issue and was on the verge of reformatting my macbook.

Here's what fixed the issue for me. I'm not sure if step one was necessary, but since I did this en route to fixing the loop of death, I'll list it here for you to consider.

  1. Try to reinstall Mojave (this won't wipe your disk) - I wanted to return my macbook to as original a condition as possible, and I figured attempting to install Mojave was the best way to do it. Since I couldn't boot from "Macintosh HD" anymore (I was just getting a white circle with a bar across it), I rebooted my macbook and pressed Cmd + r. This helped me boot into recovery mode. Once there, I clicked on "Reinstall macOS". Don't worry, you won't lose your data doing this as it merely overwrites the OS, it doesn't overwrite your files. Once you do so, and assuming you're connected to Wifi, your macbook will start downloading Mojave and eventually attempt to install it. After an agonizing 30-40 minutes, it'll give you the same error - "not enough free space to install the OS".

  2. Try restoring from Time Machine Backups (you might actually have one) - I cannot emphasize how strongly I believed I didn't have one of these backups, but unbeknownst to me, it did exist on my drive. Even if you're convinced you don't have one, it doesn't hurt to give this a shot. Reboot and go into recovery mode again (press cmd + r during reboot). This time when the options pull up, choose "Restore from Time Machine Backup". Now, as I mentioned before, I thought I hadn't got this turned on, but I guess it was turned on by default by the OS. Your macbook will prompt you to pick a disk where the time machines are stored, and I picked "Macintosh HD". When I clicked this option, I saw about 5 backups populate from today itself. I picked one of them that felt fairly far away from the moment I had began installing this OS. For example, if I started my installation at 4pm, I decided to pick up the recovery from 2pm (even though there was a backup available from 4 pm).

It took all of 5 minutes for the backup to be restored. And all my files were intact, even though I had explicitly moved out/deleted about 30G of files while trying to debug the installation issue.


  • Thanks for your response. Unfortunately, I wasn't able to reinstall Mojave and my time machine backup was too old to be useful. I took my Mac into my local Apple Store and they said they hadn't heard of something like this before. Unfortunately, they recommended wiping the Mac and reinstalling Mojave as a clean install. They said there might be a problem with Catalina if that's what caused the problem so to wait until the next incremental release before updating
    – Rocco
    Commented Oct 8, 2019 at 11:58
  • What would you think into editing it into suggesting restore from Time Machine in the first place, before corrupting anything with reinstall (which doesn't seem to work for some people by the way)? Commented Nov 5, 2019 at 19:34

I had the same problem yesterday on a 2013 Macbook Air and was able to restore a Time Machine backup. The update failed due to limited space, but it wasn't able to boot into Mojave anymore because it couldn't find a bootable disk anymore.

I tried freeing up space by manually moving the iTunes folder (~20GB) to an external drive from the terminal, but somehow it did not seem to see the extra space. It kept complaining about too little storage space (the disk repair tool saw only 11GB available).

I Tried TA's solution:

  • The reinstall of Mojave failed, again because of free space issues.
  • Then I tried to restore a Time Machine backup and also found a backup from just before the update which I hadn't expected. This restore was finished in 2 minutes and Mojave was up and running as if nothing had happened.

The next step is to make another backup, clear out even more space and re-try the update. Fingers crossed!

After restoring Mojave and clearing up enough space the update was succesful.

  • did it work ?????
    – mesqueeb
    Commented Oct 12, 2019 at 7:08
  • @mesqueeb, yes the update worked fine this time! Commented Oct 13, 2019 at 8:15

macOS High Sierra (10.13) or later have an APFS file system which does disk state snapshots which are accessible as Time Machine backup.

That means what in case of restart loop because of lack of free space you need to boot into recovery mode by holding Cmd + R right after machine starts, and go into Restore from Time Machine Backup there: you will have local time machine backups and will be able to restore system to its state just before the upgrade.

You don't need an external disk with Time Machine copy to do that, APFS does this for you automatically.

Deleting a file from APFS from recovery mode would not free any disk space because of the snapshot system, mentioned above.


I ran into the same problem yesterday with zero help from a senior advisor despite opening a ticket with engineering.

I finally resolved it by: Downloading (but not installing) Catalina on another Mac and copying the install file (big!) to an external drive. I then booted the stuck Mac to an external drive I have running High Sierra, wiped and reformatted the stuck drive, then installed Catalina from scratch. This worked, and then restored from Time Machine backup; only way I was able to get around this issue without reverting to Mojave.

Also if you come across and issue where it won’t open your TM backup because there “aren’t any volumes” skip the usual restore process and set up as new. Create an dummy account and login; then open your TM backup so the disk image is mounted in the Finder. Only then you can run the Migration Utility and it will be able to restore from your backup.

Complete nightmare but finally upgrade completed; definitely not doing my other Mac for a while.

  • Note that the external boot drive I already had running High Sierra is the full OS not the recovery utility; I didn’t try it but Mojave should work fine as well if you need to create one. Commented Oct 8, 2019 at 15:35

I followed TA's answer above although I only did step 2 - restore from Time Machine. And that seems to have worked so far.

It took about 2 hours to restore 200GB, and it was a bit nerve wracking since I had to erase my HD before doing the restore (maybe this wouldn't have been necessary had I followed step 1 and reinstalled Mojave). I thought I had plenty of space before I tried the Catalina upgrade. I had just deleted (and emptied trash) of about 50GB of Xcode device support files. So I don't understand why Catalina had the space issue for me. I'd also been reindexing Spotlight and turning off Filevault prior to the Catalina issue so maybe those were contributing factors. One tip that may be really useful for people is that if you have a wireless mac keyboard, Command R to get into recovery mode might not be easy for you to initiate. I resolved this little "gotcha" by plugging my keyboard directly into my mac.


Also discussed and resolved here:

  • 2
    Hi Sam and welcome to the site! glad that it the issue was resolved, but to make the answer better and useful for future visitors, could you please add some more details and the crucial info from the link here, in case the link breaks? That would be great!
    – anki
    Commented Oct 10, 2019 at 20:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .