1

I created a very simple shortcut.

Flashlight on/off.

Than I added that shortcut to the homescreen.

Now I start the shortcut from the homescreen.

Result: The admin interface of the shortcuts app opens (you see the list of all shortcuts).

Question: How can I prevent, that the shortcuts app opens?

Thanks for your help.

1

The only way to prevent that is to use the Shortcut "widget" instead of using a shortcut from the iOS home screen.

By "widget" I mean that screen which appears on the iOS home screen (aka "Springboard") when you are at the first screen of apps and then swipe from left-to-right.

Scroll to the bottom and tap 'Edit'

In the "Add Widgets" screen which appears, select "Shortcuts"

| improve this answer | |
  • Thanks for the hint. Widgets are not an option. I "develop" an interface in form of a homescreen for elderly people, who are in an emergency situation in the forest and want to send their coordinates to the emergency call center. I think the homescreen is the best place. I tend to regard the actual behaviour of the app (open the app, wenn you start a shortcut via the trigger "homescreen button") as a bug. Don't know, what you think about it. – ibu Oct 7 '19 at 22:23
0

You can do this by using a web clip with the URL scheme set to the app directly, rather than the Shortcuts app. These web clips can be created

| improve this answer | |
0

As mentioned earlier, you can use the shortcut widget in the widget screen.

There is an option "Show When Run" when editing or creating a shortcut. If you turn this option off, it will prevent from opening the shortcuts app.

'Show When Run

I hope this helps,

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .