0

I need to reinstall macOS on my 2011 iMac. The iMac was last running High Sierra (which is the last OS it supports) before I wiped it. I am booting into Internet Recovery mode on my iMac, but for some reason the computer seems to be retrieving Lion from Internet Recovery. This would normally be fine (I could just install Lion and then upgrade to High Sierra through the Mac App Store), but in order to install Lion, the installer asks for my Apple ID and password. I type my credentials in correctly, but the installer seems to be so old that it is unable to communicate with the Mac App Store properly, so it rejects my credentials and doesn't proceed with the installation.

Is there a way to get Internet Recovery to boot into High Sierra?

2

Since macOS Sierra 10.12.4 Apple has provided three different macOS Recovery options. These are described below:

  • commandR to reinstall the latest macOS that was installed on your Mac, without upgrading to a later version
  • optioncommandR to upgrade to the latest macOS that is compatible with your Mac
  • shiftoptioncommandR to reinstall the macOS that came with your Mac, or the version closest to it that is still available

So, the best options if you're wanting to install macOS High Sierra from Recovery mode is to use the:

  • commandR shortcut (since that's the last version of macOS you had installed), or the
  • optioncommandR shortcut as that's the one for installing the latest macOS compatible with your hardware.
1
  • For what it's worth, on my 2012 Unibody MacBook Pro, when I tried using Internet Recovery mode with a newly-formatted startup disk, command-R also gave me the OS that came with it (Lion), which caused all sorts of problems. But option-command-R gave me Catalina, which worked. I guess "the last version you had installed" is kind of meaningless when you've wiped the disk, so it uses the one that came with it. – JW. May 24 at 21:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .