0

My MacBook pro retina 15" Late 2013 8 gb RAM MacBookPro11,2 A1398 (EMC 2674 ) was shutting down by itself, and when I ran the command in terminal the log it says,

kernel: (AppleSMC) Previous shutdown cause: -128

So here's what I did:

  • Reset the PRAM & SMC

  • Did a clean install of macOS

  • Ran AHT but it shows everything is fine

  • I also did a little research in google & found out replacing the old battery with a new one may fixed this issue so I replaced the old battery and installed the new battery.

But still no luck, After doing all there thing the problem still exists so now I am thinking to replace the logic board. Should I go for it? Will this fix my problem or the problem is some where else? Any suggestions ?

I'll be buying this logic board

https://www.ifixit.com/Store/Mac/MacBook-Pro-15-Inch-Retina-Late-2013-Integrated-Graphics-2-0-GHz-Logic-Board/IF117-030?o=1,

And here are some logs.

Here is the EtreCheck report if it can help. This Report is from before doing a clean install of macOS.

EtreCheck Report EtreCheck version: 5.2 (5C006)

Report generated: 2019-09-30 13:43:35

Download EtreCheck from https://etrecheck.com

Runtime: 2:11

Performance: Excellent

Problem: Other problem

Major Issues:

Anything that appears on this list needs immediate attention.


No Time Machine backup - Time Machine backup not found.

System Integrity Protection disabled - System Integrity Protection is disabled. This computer is at risk of malware infection.
Minor Issues:

These issues do not need immediate attention but they may indicate future problems or opportunities for improvement.


Clean up - There are orphan files that could be removed.

32-bit Apps - This machine has 32-bits apps will not work after macOS 10.14 “Mojave”.
Hardware Information:

MacBook Pro (Retina, 15-inch, Late 2013)

MacBook Pro Model: MacBookPro11,2

1 2 GHz Intel Core i7 (i7-4750HQ) CPU: 4-core

8 GB RAM - Not upgradeable

    BANK 0/DIMM0 - 4 GB DDR3 1600  ok

    BANK 1/DIMM0 - 4 GB DDR3 1600  ok

Battery: Health = Normal - Cycle count = 0
Video Information:

Intel Iris Pro - VRAM: 1536 MB

    Color LCD 2880 x 1800
Drives:

disk0 - APPLE SSD SM0256F 251.00 GB (Solid State - TRIM: Yes)

Internal PCI 5.0 GT/s x2 Serial ATA

    disk0s1 - EFI (MS-DOS FAT32) [EFI] 210 MB

    disk0s2 [APFS Container] 250.79 GB

        disk1 [APFS Virtual drive] 250.79 GB (Shared by 4 volumes)

            disk1s1 - m***S (APFS) (Shared - 170.63 GB used)

            disk1s2 - Preboot (APFS) [APFS Preboot] (Shared - 45 MB used)

            disk1s3 - Recovery (APFS) [Recovery] (Shared - 517 MB used)

            disk1s4 - VM (APFS) [APFS VM] (Shared - 2.15 GB used)
Mounted Volumes:

disk1s1 - m***S 250.79 GB (77.31 GB free)

    APFS

    Mount point: /


disk1s4 - VM [APFS VM] (Shared - 2.15 GB used)

    APFS

    Mount point: /private/var/vm
Network:

Interface en5: BlackBerry

Interface en4: iPhone

Interface en0: Wi-Fi

    802.11 a/b/g/n/ac

Interface en3: Bluetooth PAN

Interface bridge0: Thunderbolt Bridge

iCloud Quota: 4.44 GB available
System Software:

macOS Mojave 10.14.3 (18D109)

Time since boot: About 2 days
Notifications:

~/Downloads/EtreCheckPro.app

    one notification



    one notification (one scheduled)
Security:

Gatekeeper: Enabled

System Integrity Protection: Disabled
32-bit Applications:

One 32-bit app
Kernel Extensions:

/Library/Extensions

    [Not Loaded] BlackBerryUSBCDCNCM.kext (BlackBerry Limited, 1.0.15 - SDK 10.7)

    [Not Loaded] HoRNDIS.kext (Joshua Wise, 9.2 - SDK 10.11)

    [Loaded] ufsd_NTFS.kext (Paragon Software GmbH, 15.4.11 - SDK 10.10)

    [Not Loaded] RIMBBUSB.kext (BlackBerry Limited, 2.2.17 - SDK 10.7)
System Launch Agents:

[Not Loaded] 17 Apple tasks

[Loaded] 162 Apple tasks

[Running] 120 Apple tasks
System Launch Daemons:

[Not Loaded] 34 Apple tasks

[Loaded] 179 Apple tasks

[Running] 121 Apple tasks

[Other] One Apple task
Launch Agents:

[Running] com.bjango.istatmenus.agent.plist (Bjango Pty Ltd - installed 2019-09-30)

[Running] com.bjango.istatmenus.status.plist (Bjango Pty Ltd - installed 2019-09-30)

[Other] com.epson.ecrp.launcher.plist (? 5de78af0 - installed 2018-08-02)

[Other] com.epson.esua.launcher.plist (? 70512568 - installed 2018-08-02)

[Other] com.epson.eventmanager.agent.plist (? cd93600d - installed 2016-12-09)

[Running] com.paragon-software.ntfs.notification-agent.plist (Paragon Software GmbH - installed 2018-09-19)

[Other] com.rim.BBLaunchAgent.plist (? c583fbf8 - installed 2016-01-22)
Launch Daemons:

[Loaded] com.apple.installer.osmessagetracing.plist (Apple - installed 2019-02-05)

[Running] com.bjango.istatmenus.daemon.plist (Bjango Pty Ltd - installed 2019-09-30)

[Running] com.bjango.istatmenus.fans.plist (Bjango Pty Ltd - installed 2019-09-30)

[Loaded] com.bjango.istatmenus.installerhelper.plist (Bjango Pty Ltd - installed 2019-09-30)

[Loaded] com.daisydiskapp.DaisyDiskAdminHelper.plist (? de20d690 - installed 2018-11-23)

[Loaded] com.microsoft.office.licensingV2.helper.plist (Microsoft Corporation - installed 2016-06-11)

[Running] com.paragon-software.installer.plist (Paragon Software GmbH - installed 2018-12-02)

[Loaded] com.paragon-software.ntfs.loader.plist (Apple - installed 2019-02-05)

[Running] com.paragon-software.ntfsd.plist (Paragon Software GmbH - installed 2018-09-19)

[Other] com.rim.BBDaemon.plist (? 9f895e8a - installed 2016-01-22)
User Launch Agents:

[Loaded] com.google.keystone.agent.plist (Google, Inc. - installed 2019-05-18)

[Loaded] com.google.keystone.xpcservice.plist (Google, Inc. - installed 2019-05-18)

[Not Loaded] com.microsoft.OneDriveMigrationLauncher.plist (? 0 - installed 2018-11-22)
User Login Items:

BandwidthLauncher (App Store - installed 2019-03-27)

    (Modern Login Item - /Applications/Bandwidth+.app/Contents/Library/LoginItems/BandwidthLauncher.app)


FSMenuAppLoginItemHelper (Paragon Software GmbH - installed 2018-12-02)

    (Modern Login Item - /Applications/NTFS for Mac.app/Contents/Library/LoginItems/FSMenuAppLoginItemHelper.app)


Google Chrome.app (Google, Inc. - installed 2019-09-27)

    (Application - /Applications/Google Chrome.app)
User Internet Plug-ins:

Folx3Plugin: (?)
Audio Plug-ins:

AppleTimeSyncAudioClock: 1.0 (Apple - installed 2018-12-22)

BluetoothAudioPlugIn: 6.0.10 (Apple - installed 2019-02-13)

AirPlay: 2.0 (Apple - installed 2019-02-13)

AppleAVBAudio: 710.1 (Apple - installed 2018-12-22)

BridgeAudioSP: 5.2 (Apple - installed 2019-02-13)

iSightAudio: 7.7.3 (Apple - installed 2018-12-22)
Safari Extensions:

Folx - App Store (installed 2018-11-13)
3rd Party Preference Panes:

NTFS (installed 2018-09-19)
Time Machine:

Time Machine Not Configured!
Performance:

System Load: 2.16 (1 min ago) 2.13 (5 min ago) 2.01 (15 min ago)

Nominal I/O speed: 0.09 MB/s

File system: 20.87 seconds

Write speed:  643 MB/s

Read speed:  779 MB/s
CPU Usage Snapshot:

Type Overall

System 7 %

User 9 %

Idle 83 %
Top Processes Snapshot by CPU:

Process (count) CPU (Source - Location)

mds 47.34 % (Apple)

mds_stores 38.86 % (Apple)

Google Chrome 7.54 % (Google, Inc.)

Google Chrome Helper (Renderer) (15) 6.57 % (Google, Inc.)

EtreCheckPro 5.58 % (Etresoft, Inc.)
Top Processes Snapshot by Memory:

Process (count) RAM usage (Source - Location)

mdworker_shared (40) 1.06 GB (Apple)

Google Chrome Helper (Renderer) (15) 944 MB (Google, Inc.)

EtreCheckPro 885 MB (Etresoft, Inc.)

MTLCompilerService (50) 583 MB (Apple)

com.apple.WebKit.WebContent (20) 579 MB (Apple)
Top Processes Snapshot by Network Use:

Process Input / Output (Source - Location)

mDNSResponder 148 KB / 140 KB (Apple)

netbiosd 17 KB / 11 KB (Apple)

cloudd 8 KB / 2 KB (Apple)

apsd 4 KB / 5 KB (Apple)

SystemUIServer 0 B / 192 B (Apple)
Top Processes Snapshot by Energy Use:

Process (count) Energy (0-100) (Source - Location)

mds_stores 43 (Apple)

mds 41 (Apple)

WindowServer 4 (Apple)

mdworker_shared (40) 1 (Apple)

Google Chrome 0 (Google, Inc.)
Virtual Memory Information:

Physical RAM: 8 GB


Free RAM: 119 MB

Used RAM: 6.51 GB

Cached files: 1.37 GB


Available RAM: 1.49 GB

Swap Used: 137 MB
Clean up:

/Library/LaunchDaemons/com.rim.BBDaemon.plist

    BBDaemon

    Executable not found

~/Library/LaunchAgents/com.microsoft.OneDriveMigrationLauncher.plist

    /Applications/OneDrive.app/Contents/MacOS/OneDrive

    Executable not found

/Library/LaunchAgents/com.epson.ecrp.launcher.plist

    /Applications/Epson Software/Epson Utilities/Epson Customer Research Participation.app/Contents/MacOS/Ecrp

    Executable not found

/Library/LaunchAgents/com.rim.BBLaunchAgent.plist

    BBLaunchAgent

    Executable not found

/Library/LaunchAgents/com.epson.eventmanager.agent.plist

    /Applications/Epson Software/Event Manager.app/Contents/Resources/Assistants/Event Manager/EEventManager.app/Contents/MacOS/EEventManager

    Executable not found

/Library/LaunchAgents/com.epson.esua.launcher.plist

    /Applications/Epson Software/EPSON Software Updater.app/Contents/EPSON Software Updater Agent.app/Contents/MacOS/EPSON Software Updater Agent

    Executable not found
Diagnostics Information (past 7 days):

2019-09-30 13:25:00 mds_stores Crash (3 times)

    Executable: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Support/mds_stores

    Details:

        dyld3 mode

        [0x70000d45c000] disk_utils.h:486: failed assertion '(b4 & 0x80) == 0'

         /.Spotlight-V100/Store-V2/D98546F7-5673-4B74-A8BE-39BDC37D40F7 (apfs,

         t: 0x19, st: 0x1, f: 0x480d000)

        [0x70000d7f1000] Setting index emergency state

        Initializing
End of report 

After doing clean install of mocos Terminal logs

    Last login: Mon Sep 30 13:42:47 on ttys001

shivangs-MacBook-Pro:~ shivang$ log show --predicate 'eventMessage contains "Previous shutdown cause"' --last 1h

Filtering the log data using "composedMessage CONTAINS "Previous shutdown cause""

Skipping info and debug messages, pass --info and/or --debug to include.

Timestamp Thread Type Activity PID TTL

2019-09-30 13:20:52.006253+0530 0x23ff Default 0x0 0 0 kernel: (AppleSMC) Previous shutdown cause: -128

2019-09-30 13:22:42.006295+0530 0x2789 Default 0x0 0 0 kernel: (AppleSMC) Previous shutdown cause: -128

2019-09-30 13:23:35.014048+0530 0x2949 Default 0x0 0 0 kernel: (AppleSMC) Previous shutdown cause: -128

2
  • 1
    Error code 128 is listed as because of a power failure or an automatic reset following initiating the SMC on boot up. If your case it may because there a small component on the logic board that’s not getting the correct voltage to correctly power your fans, keyboard, trackpad ect. There may be services available that can physically run a diagnostic check and replace the part, rather than buying an entire logic board. Can someone chime in on this > I’m curious if you remove SMC related kext files and use usb keyboard & mouse, will the SMC will still demand the same amount of power?
    – Theologin
    Commented Oct 3, 2019 at 21:35
  • 1
    I had a similar issue on my MacBook Pro of the same model. It sounds like your problem may be this random shutdown issue. I recommend trying the solution in the top answer (renaming the AppleThunderboltNHI.kext file) before installing a new logic board.
    – D. Gillis
    Commented Oct 7, 2019 at 4:48

0

You must log in to answer this question.

Browse other questions tagged .