4

Are there any processor upgrades I can use to allow me to run Catalina on my trusty 2012 Mac Pro 5,1 ?

Thanks

Update!

It worked using http://dosdude1.com/catalina. Veering slightly from the video, I cloned my Mojave startup drive, and installed on the clone.

At the point in the app and video where you are asked to make a USB drive installer, I selected "install to Computer". This worked!

After the install, the patcher app starts and installs some more patches.

So far, so good.

However, I don't know how long this system will work! Will I be able to use Software Update? Use at your own risk!

Please watch the video and use it as a guide.

enter image description here

  • Can you link us to the requirement page of Catalina.. just to save us the trouble and increase research effort? – ankii Oct 3 at 19:59
  • here you go > support.apple.com/en-us/HT210222 – David DelMonte Oct 3 at 20:51
  • everymac.com/mac-answers/macos-catalina-faq/… This lists the cores, clock speeds and screen sizes(relevant?) of all supported Macs. You could find the closest one I hope – ankii Oct 4 at 5:18
  • Are you already on Mojave - ie do you already have the necessary Metal-compatible GPU? If so, is it Mac-flashed? Do you see the screen before login? [Apple never made a Metal-capable GPU as a PCI-e card, so it would have to be a 3rd party, HD7950 etc] There are no drivers for NVidia after High Sierra. – Tetsujin Oct 4 at 6:21
2

There is a macOS Catalina Patcher by @dosdude1 that is supposed to be compatible with Mac Pro 5,1. As of this moment, it is currently confirmed to working with Dev Preview 9 and Public Beta 8.

With modifications like this, there is always the risk of data loss or bricking, so make sure to have good backups and follow directions carefully.

  • Thanks!! I'm trying that now on a spare drive. – David DelMonte Oct 3 at 20:50
  • Here's the YouTube tutorial for this: youtube.com/watch?v=uQfcolvfAHM – David DelMonte Oct 3 at 20:54
  • I've run into this issue - "asr: Couldn't personalize volume /Volumes/macOS Base System - Operation not permitted" - would it help to get another flash drive? Thanks – David DelMonte Oct 3 at 21:42
  • @DavidDelMonte: Unfortunately, I have not used this software myself, so I don't have troubleshooting steps for you to try. – drivec Oct 3 at 22:11
  • I’ll try a new drive. Thanks for letting me know – David DelMonte Oct 3 at 22:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .