4

After upgrade to iOS 13 from 12.4, I noticed that personal hotspot isn't working anymore over Wi-Fi (via USB is ok).

Tested on two computers with Win7. The PC can connect to Wi-Fi, but no valid IP (IPv4) is assigned and no connection is working to internet.

  • why to downgrade. Update to iOS 13.1 . iOS 13.0 had a lot of bugs – Udhy Oct 3 at 14:20
  • I already have 13.1 :(((((((( – user1797147 Oct 3 at 14:23
  • okay. If you haven't downgrade then first reboot your machine and try again (sound weird but major solution for many things). Then, one more point SSID comes with your iPhone name. Change it if you want and check it. In windows, if you have already connected with same SSID, then I would suggest try with new password and check it. – Udhy Oct 3 at 14:31
4

I found a workaround which works fine for me.

While connected to the hotspot open a cmd and enter the following commands:

  1. ipconfig /release
  2. ipconfig /renew

After that, the client gets instantly a correct IP-Adress from the DHCP.

  • thanks a lot, I just created a batch file for that. Until Apple will bother to fix this embarrassment, this is the quickest fix I found so far. – orfruit Oct 15 at 6:08
  • Working for me! – Marco Marsala Oct 24 at 6:20
  • Is there a way to do this on MacOS? – Qasim Nov 27 at 9:34
2

Seems that iOS 13.1.2 Personal Hotspot's DHCP is not working, at least on Win7. What what was done was assigning client IP manually (on the PC)

IP Address: 172.20.10.11
Subnet Mask: 255.255.0.0
Router: 172.20.10.1
DNS: 172.20.10.1

Now is working.

  • this is OP's answer, which was removed from the question and put into a CW to avoid reputation stealing. – ankii Oct 11 at 10:56
  • Thanks for this. Please can you give more details about how to assign a client IP manually on Windows 7. I haven't found where I should enter this information. – ruffle Oct 12 at 22:38
  • howtogeek.com/howto/19249/… Settings are almost same across multiple win versions. and I am a Mac user :), superuser.com to the rescue. – ankii Oct 12 at 22:41
  • Working for me too – Marco Marsala Oct 24 at 6:20
0

I got it to work in IOS 13.1.2.

  1. Look for "connect manual network" on your computer.
  2. Type in the exact name of your hotspot
  3. Choose WPA2
  4. Type Password and tap Connect.

It is important you do not select the hotspot from the Wi-Fi list, that does not seem to work for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .