4

When I try to connect to WiFi on ICE using MacBook Pro, I am not prompted with a WiFi login screen. This is however not a problem on my iPhone and other devices but persists specifically on my MacBook Pro. I have also seen people asking the solution for the same problem on various websites/forums but in vain. I was wondering if there were any consistent solution or troubleshooting steps to follow to make it work?

0

8 Answers 8

6

Troubleshoot WIFIONICE MACBOOK (wifi on ice)

  • Disconnect wifi
  • sudo killall -HUP mDNSResponder
  • go to System Preferences > Network > (Select) Wifi > Advanced > DNS to add a sample dns 8.8.8.8
  • Connect wifi And go back clear the DNS added.
  • Reload the http://wifionice.de/de/ website and start surfing.

(This method works for me consistently)

6
  • "Go to advanced" is rather unclear, what exactly do you mean by that?
    – nohillside
    Commented Oct 1, 2019 at 18:33
  • I think it means Menu Bar > wifi icon > Open Network Preferences > Advanced > DNS tab Commented Oct 1, 2019 at 19:05
  • There is no sane way why messing with your DNS should help with captive portal problems
    – averell
    Commented Oct 2, 2019 at 15:12
  • For me, removing the existing DNS entry (8.8.8.8) did the job
    – omnesia
    Commented Aug 17, 2022 at 15:52
  • Changing DNS entry to 172.18.0.1 (first one) works for me. This is required to make resolving wifionice.de to the actual portal site.
    – Phlogi
    Commented Mar 11 at 10:52
3

I encountered the same problem, but already had 8.8.8.8 as my DNS server before the problem occurred on my machine. Clearly, this was blocking to resolve the wifionice.de on their dns.

To resolve the problem, I simply removed this DNS server from the list in: System Preferences > Network > Wifi > Advanced > DNS (similar to that part of the solution suggested by rajesh david). Click apply and return to wifionice.de.

2
  • 2
    This solved it for me. Using 8.8.8.8 as custom DNS server seems to cause the WIFIOnICE login page to not resolve.
    – Erikw
    Commented Jul 7, 2023 at 6:01
  • @Erikw plain normal. Since your are on a closed icd.de network you got a private IP address, and 8.8.8.8 Google DNS server is unreachable at the beginning. I don't know where this DNS configuration came from but it can only work on a network where you have a public IP address.
    – dan
    Commented Apr 14 at 12:07
2

For me, adding the DNS 172.18.0.1 worked (saw it on my android on which the WiFi was working fine).

1

In July 2022 MBP Latest Version OSX I got same problem. Tried some command line fu, no luck.

What did work was deleting the DNS records in network settings. Spend good 45m messing about with this issue. Does not seem to effect OSX 15.5.

Very usable free connection Wi-Fi on DB gotta love German trains!

1
  • "OSX 15.5" - I'm guessing you mean 12.5?
    – agarza
    Commented Aug 7, 2022 at 17:46
1

I encountered an issue where I was able to connect to the wifi network 'WIFIonICE', but the pop-up to accept the privacy and terms of service did not appear.

To resolve this issue, I found that keeping the connection active and going to the wifi settings, then clicking on DNS, and removing any existing DNS (such as 4.4.4.4 or 8.8.8.8) allows the network to assign its own DNS to the system/connection.

After that, opening the website login.wifionice.de in my browser allowed me to successfully connect to the wifi.

1

Do not delete DNS entries. Sometimes, there are company-specific entries in there, especially if it's not a privately used MacBook. You might encounter issues after the train ride.

If you are already connected to the network, this is usually a DNS resolution problem. There are probably already DNS settings in the corresponding WiFi network card. Important, you do not need to delete existing DNS entries (as described in other posts).

  1. Check whether you are really already connected to the WLAN "WIFIonICE". You should have received a private IPv4 address from the range 172.18.0.0/16.
  2. Add a new DNS Server. The IP of that server is 172.18.0.1. To change these settings, choose Apple menu > System Settings, click Wi-Fi in the sidebar, click a WIFIonICE service on the right, click Details, then click DNS.
  3. The order of the DNS servers is not important.
  4. Switch off the Wi-Fi for a short moment.
  5. Turn on Wi-Fi.

The connection should then work and when you call up a website you should be taken to the Deutsche Bahn captive portal.

In a few cases you have to delete the local DNS cache of the MacBook after entering the DNS server.

On your MacBook, do one of the following:

  1. Click the Launchpad icon in the Dock, type Terminal in the search field, then click Terminal.
  2. In the Finder, open the /Applications/Utilities folder, then double-click Terminal.
  3. Execute the following command in the terminal window: sudo dscacheutil -flushcache; sudo killall mDNSResponder

DNS Wi-Fi settings on Ventura

0

If this happens, it is usually one of two things:

  • The connection itself is flaky
  • The Macbook did not „pick up“ the login page

First check if your WiFi is connected (connection Symbol and no exclamation mark). If it is, open your browser and go to http://neverssl.com - this should usually get you the login page.

These steps should also work for other networks that require a login.

If it does not connect, the train‘s system may be offline...

0

This worked for me:

  1. Connect to the Wifi
  2. in your browser go to http://captive.apple.com
  3. The iceportal.de page will load and you will be able to surf.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .