2

My mac has suddenly stopped letting me freely move around my application windows around the screen, and its just allowing them to be shown in a grid view. If i try resizing windows, they just get automatically resized back. I've tried searching for some kind of setting in accessability, but i have not found out how to turn this off, its driving me mad.

Attached are screenshots of how it forces the layout of windows present

enter image description here

It is not possible to resize any of the windows here, and there is always a blue rectangle around the window with focus

enter image description here

with 2 windows showing, they are forced into this layout

  • Never saw this though, but If you can access launchpad, see if any app is doing so.. There are window splitter apps available. I would be surprised if it is natively possible. – ankii Sep 30 '19 at 8:02
  • Did you install any new application or tool recently? – nohillside Sep 30 '19 at 8:08
  • no i have not installed anything recently, it seems really similar to any split window auto layout apps yes. I've looked through task manager to see if any are running, and it does not seem like it. I've also removed every app from login items, and restarted – bogen Sep 30 '19 at 8:11
  • have you checked whether any key has been pressed from your keyboard? Just try to clean the keyboard and see as blue rectangle goes or not. – Udhy Sep 30 '19 at 8:25
  • yes i tried checkin on screen keyboard if any keys were pressed – bogen Sep 30 '19 at 8:45
6

Clearly your computer has a window manager installed on it.

That one in particular might be chunkwm (the blue border around your selected window reminds me of my time using chunkwm, but I assume all window managers provide some feature like that). chunkwm is also very popular, so maybe it's what's ended up installed on your computer.

Try stopping it, maybe one of these commands will work:

brew services stop chunkwm
launchctl unload -w ~/Library/LaunchAgents/com.koekeishiya.chunkwm.plist
launchctl unload -w ~/Library/LaunchAgents/homebrew.mxcl.chunkwm.plist

if none are found try searching for it

launchctl dumpstate | grep chunkwm

if chunkwm still isn't found, then the window manager you have isn't chunkwm.

Just look up a list of window managers online and search for each one in turn on your computer.

It might also be possible to hunt through

launchctl dumpstate | grep '=> true' 

for it.

|improve this answer|||||
  • 1
    Now I am wondering how OP got it without their knowledge. Is it available by default? – ankii Sep 30 '19 at 8:42
  • 5
    @ankii no, you have to install it yourself. In fact, iirc, it requires quite a lot of steps to install and set up. – theonlygusti Sep 30 '19 at 8:42
  • maybe something i installed along time ago, and something just activated it? – bogen Sep 30 '19 at 8:44
  • I actually fixed the problem now with checking "Displays have separate spaces" in Mission Control. Seems like a bug that that fixed it though, and i think your solution might also have worked. I think i had installed that plugin long time ago, but have no idea why it suddenly was activated now, since i basically never used it – bogen Sep 30 '19 at 8:45
  • 1
    Out of curiosity, how would one discover the list of third party software they have installed (that might do this)? – Harper - Reinstate Monica Sep 30 '19 at 18:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .