0

With the goal of recovering storage space, I attempted to delete the Apple TV App. This app was still taking up 490MB of "Documents and Data" storage after I deleted all videos I could manually delete (the TV app libray screen said "You don't have any videos.") However, deleting the TV app only changed it to "Videos" which still takes up 490MB of "Documents and Data" storage.

There is no option to delete this "Videos" pseudo app. As far as I can tell, there is no actual "Videos" app I can start from the home/search screens.

I also tried to locate the media file(s) taking up storage via iTunes. There was one file under "Movies." There was no option to delete this file from iTunes. I think I uploaded the file to my iPhone via CopyTrans Manager. So I tried deleting the file via CopyTrans.

Now the file does not show up in iTunes or CopyTrans, but the "Videos" app still consumes 490MB of storage. How do I recover the 490MB of storage taken up by the "Videos" app?

I have a feeling this file was orphaned somehow because it was uploaded a long time ago on different versions of iOS/iTunes/copyTrans before the Videos app became the TV app.

I read syncing may result in files that cannot be deleted. Since I manually manage the media on my iPhone, all sync settings have been set to disabled.


update: Now I have the same problem for the Music app: no files in library, but "documents and data" takes up 318MB of storage after I tried toggling the Movie sync on/off. Even though I only enabled syncing for movies there was a warning that the music would also be deleted since the library was empty. The music was deleted, but the storage was not...

  • my go to for such is: backup, wipe, restore. You can also order a movie that won't fit on your iOS device. iOS will try and make it fit by deleting unused/cached data, often clearing the space you need. I have not tried the latter tho, just heard it a few times... – Steve Chambers Sep 29 '19 at 23:05
  • 1
    @SteveChambers: yes, restore seems to be the solution – Leftium Sep 30 '19 at 0:23
1

So a system restore (I actually upgraded to iOS 13) fixed the problem. I had been trying to reduce the size of the backup before upgrading, but perhaps it would not have affected the backup size.

This article gives background info on why there might be "zombie" storage usage even after deleting the files: How to Delete Documents & Data on iPhone or iPad. (TDLR: "caches, app data, preferences, login details, and assorted other app-specific information")

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .