7

I know roll-outs are staggered, but 10 days (and two minor releases) later I'm fairly sure I should have been offered an update (all other iOS/iPadOS devices in the house have been).

I've restarted the phone, logged on to various networks (plus cellular), and I'm still seeing

iOS 13.0
Your software is up to date.

When visiting Settings / General / Software Update

Automatic updates are On, iCloud setup is fine (backups working, etc.), and this phone is not enrolled in any betas. The update from 12.x to 13.0 was via iTunes, but I've done that before and (as expected) it's had no effect on future OTA updates.

Any magical bonus steps I might take to cause the phone to discover the update?

  • It's not uncommon to take several days for a new update to be available. This is especially true when it coincides with a new iPhone release. You should give it another day or two and see what happens. What's your physical location? – fsb Sep 26 '19 at 19:34
  • Florida. And as I said, all the other devices on the same network are being offered the update (or have already updated), so the exception seems increasingly odd. I've seen 1-day delays before, but never two. – Paul Roub Sep 26 '19 at 20:31
  • 1
    To whomever is down voting the question and answers, don’t shoot the messengers. Paul’s issue is well stated and valuable. Udhy is fleshing out “the usual” for people that might not know how to step by step toggle the settings. – bmike Oct 5 '19 at 20:21
  • Do you by any chance have an old iOS beta profile installed on your device ?? - if you have then delete it and restart your device, and if you need to be able to install new beta releases, the you need to install a new profile. – Rene Larsen Oct 6 '19 at 8:05
  • And have you tried to just restart your device, and then try an OTA update again ?? – Rene Larsen Oct 6 '19 at 8:09
2
+25

The sure fire way to get an update now is to use Apple Configurator 2

  1. https://support.apple.com/apple-configurator
  2. Connect over USB and update

OTA updates are staged and depend on caching / CDN and other things out of your control the first 7+ days of a major release in my experience. One way you could pick this apart is to use USB networking and capture the traffic between iOS and Apple’s update servers and perhaps see an error condition.

Charles Proxy is excellent for this sort of deep dive as well when networking isn’t working.

The above tools do not need Apple support or a paid developer account. The below option I believe is only available if you have a log in as a developer or Apple sends you the profile as part of a support engagement.

There is a software update debug log profile and if you instal one that’s properly signed by Apple, you can get text logs from your specific device to answer why it’s not updating or perhaps know when the checks happen or what might be blocking them:

The above documentation has a PDF guide and the Configuration Profile required to enable logging for this situation.

| improve this answer | |
  • I know I can work around via iTunes or configurator - but given that I’m still not seeing the update on just this one of 6 iOS/iPadOS devices in the home (all on the same network, hitting the same CDN nodes, etc.) I’d like to figure out why so this doesn’t happen again. – Paul Roub Sep 29 '19 at 13:00
  • At a week+ after 13.1, and with both 13.1.1 and 13.1.2 out since, do you still think all's well here? Again, I know I can go the iTunes or Configurator route, but that's not the question. The question is why this phone, in particular, can't seem to see updates. How long would this need to go on before you'd start to doubt your initial assessment? – Paul Roub Oct 2 '19 at 15:54
  • Right, but the questions is why? Do you, at this late-ish date, still think this is just an outlier on the spectrum of normal delays? And if so, how many days/weeks/months before you might question that? (100% curiosity, 0% snark here, BTW) – Paul Roub Oct 2 '19 at 16:52
  • I think it’s normal for a week or so, but clearly yours is stuck and needs intervention @PaulRoub See my edit on how I would debug this further by enabling logging on iOS or trying to capture the traffic and see if there is an error that makes sense. – bmike Oct 5 '19 at 20:11
1

In case you’re not sure how to toggle the settings,

  1. Connect the internet with cellular.
  2. Go to .. General → Setting → Software update
  3. While connecting to the apple server, try cellular internet off and on until the "Automatic Updates" options display. (try two to three times above procedure)
  4. When "Automatic Updates" options display, change "on" → "off".
  5. Connect the internet again and this time ios13.1 update will be displayed.
| improve this answer | |
  • Sadly, no change with this. FWIW I always had the Automatic Updates option available, and have tried all variations of this before -- cellular, wifi, restarting in between changes, etc. – Paul Roub Oct 4 '19 at 13:20
  • Is there a reason why cellular is better than WiFi in step 1 in your experience? I’m guessing it’s to force one possible connection when you “jiggle the handle” in step 3, but maybe you have some more comments after the procedure to add? – bmike Oct 5 '19 at 22:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .