1

I wanted to clean a MacBook Pro 15,2 with Touchbar. However I noticed that it wasn't running smoothly, so I backed it up using the Target Disk mode and erased the disk, because the Recovery partition was corrupted and didn't boot (a major red flag, that i sadly ignored).

Next I created a Mojave install media, conected it and booted up with Alt pressed. However when I selected the icon the Macbook pro went to start internet recovery, so I waited for it to finish.

The bar filled up, mac rebooted and after the apple logo and bar showed up there was high fan spin and then another reboot. Of course it didn't boot into recovery it just showed the "missing files" sign, which is not suprising. (I repeated the process several times, but nothing changed.)

Then I tried everything. Atempting to boot from anything external fails (and it doesn't see TimeMachine backups) and loads internet recovery. I flashed the "BaseSystem.dmg" from the installer to the internal drive, it shows up in the bootmanager, but no luck.

Only idea I have to put all the files from the backup back in, but who knows.

I'll be glad for any advice. Thank you.

1

Presumably your data on the backup is fine, it just doesn't have the correct boot sectors or they are corrupted. Why not go thru with the internet recovery, get your Macbook to a base state, then you can use Migration Assistant to move files from your backup to the now refreshed Macbook.

1
  • Unfortunately the intenet recovery doesn't work. I can connect to Wifi, then wait about 10min but after the computer reboots the recovery doesn't load. The loading bar barely even moves and then the fans spin loud for a second and then it reboots again.
    – Tendali11
    Sep 26 '19 at 15:18
1

MacBook Pro 15,2 is the 2019 13-inch model. It has T2 chip in it. By default, it forbids booting from an external drive. Search for 'T2 chip secure boot' for more info.

It requires a valid macOS and Recovery to disable secure boot.

Currently you have to use internet recovery to install the OS, or head to an Apple shop.

1
  • OK, but that still doesn’t answer why the internet recovery doesn’t load. But I’ll take your advice and take it to an Apple Shop.
    – Tendali11
    Sep 27 '19 at 21:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .