20

I’ve been using my Mac all year without fear. On Tuesday I shut it down as I was going out of town. Today, I tried booting up my Mac and it won't boot.

I tried resetting PRAM and SMC, but no go. I did the command D thing, but no issues reported.

  • 5
    Which Mac do you have and which macOS is it running? – lhf Sep 26 at 13:28
60

I’m going to jump out on a limb here and make the assumption that you’re probably a Chrome user and before you went away you updated Chrome.

If so, you're probably the victim of a Chrome updater bug and your issues are not related to your Apple hardware nor a bug with macOS.

NOTE: If you're running Mac OS X El Capitan or later and have not disabled SIP, then this will not be the cause of your problem, in which case you'll need to skip this answer and investigate other causes!

To rectify this, you need to follow these steps:

  1. Boot into recovery mode by using the commandR keyboard shortcut upon powering up your Mac.

  2. When you see the macOS Utilities window, go to the Utilities menu bar option and select Terminal

  3. In terminal, enter the following commands one by one, followed by pressing the enter key (NOTE: If your Mac hard drive is not called Macintosh HD then you will need to change the first command below to reference the name of your hard drive)

    chroot /Volumes/Macintosh\ HD
    rm -rf /Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle
    mv var var_back
    ln -sh private/var var
    chflags -h restricted /var
    chflags -h hidden /var
    xattr -sw com.apple.rootless "" /var
    
  4. Now reboot your Mac.

Further reading:

You may be interested in reading:

  • 6
    How did you think of this, given the OP description of the problem?? The Chrome bug only affects systems with SIP disabled. – lhf Sep 26 at 12:38
  • 8
    OMG! This freaking worked! You totally saved me!! – user347757 Sep 26 at 12:50
  • 27
    @lhf Yeah, like I said, I was going out on a limb with my answer. My thought process was as follows: Many Uni students use Chrome because of its integration with Google’s services and because many online Uni dashboards have some compatibility issues with Safari. That, along with the timing of two days ago meant that it lined up with the timing of the Chrome update. As an aside, SIP only needs to be disabled if the user is running El Capitan or later (obviously) so this issue can affect other systems. In this case we don’t have that info re the OP either way. – Monomeeth Sep 26 at 13:18
  • 3
    I wouldn't say that a user-mode application making the OS unable to boot isn't a bug in the OS, but at least there's a workaround :) – Luaan Sep 27 at 8:32
  • 5
    @Luaan It's not a user mode application. It's an updater with admin priviledges. And those by definition have to be able to ruin the OS. (You can make accidental damage less likely with ACLs on system files and things like SIP, but an administrator has the ability to disable those, otherwise he's not really an admin) – Voo Sep 27 at 9:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .