1

I'm on macOS Mojave, Mail is version 12.4.

Problem

I've just realized that cmd + delete is deleting (ie irretrievably removing from my machine and server) my emails instead of moving them to the trash. I want my emails to go to the trash so I can recover them later if needed. I would like to change the behavior of that keyboard shortcut, but I doubt that's possible on macOS so I'd settle for adding a new shortcut. However, I can't figure out how to do that.

What I've tried

I've tried changing the mailbox behavior, which is what others have suggested, but there doesn't seem to be an option (see screenshot below). I'm using MailFence if that's important.

screenshot of Mailbox Behavior in Mac Mail app

I've tried adding a keyboard shortcut specific to Mail (see screenshot below), but it isn't doing what I want. Note that I have tried to name the shortcut 'Move to Trash', 'Move to trash', and 'Move to Trash Foo' where 'Foo' is the mailbox description and when I use the menu to move a message into trash I select Message -> Move to -> Trash -> Foo

screenshot of adding a Mac Mail keyboard shortcut

  • About a week ago I tried to test this again, and simply pressing the delete button now sends mail to the server's trash. I can confirm this by going to the trash can on Mac Mail, and by going to mailfence.com, logging in, and looking at the trash there. I did not change anything and yet it's working. I may have deleted it and re-added it for an unrelated issue, so maybe that solved it? – Jason Fry Oct 22 '19 at 13:53
2

Actually, you don't need to go to all this effort. The default command+delete keyboard shortcut will do exactly what you want, so long as you've set your Mail preferences that way.

In summary, you need to:

  1. Go to Mail > Preferences
  2. Select the Accounts tab
  3. Select the account (or email address) from the left pane
  4. In the right pane, select the Mailbox Behaviours tab
  5. At the bottom, tick the checkbox for Move deleted messages to the Bin mailbox
  6. While at it, ensure that the other settings on this tab for erasing deleted messages are what you want

Now when using the command+delete keyboard shortcut to delete emails they will be moved to the Bin mailbox for the Account in question.

|improve this answer|||||
  • Unfortunately that is impossible. See my original post, particularly the first screenshot I attached. That checkbox simply isn't there. From my OP, "I've tried changing the mailbox behavior, which is what others have suggested, but there doesn't seem to be an option (see screenshot below). I'm using MailFence if that's important." – Jason Fry Sep 28 '19 at 11:51
0

The best I can tell, simply removing and re-adding the mail server was enough to fix this issue. I don't know of anything else I did.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .