6

As of Safari 13.1 (perhaps earlier versions as well), Safari has changed the search bar behavior: where the first result used to always be "do a search on search engine with the text I entered", the first result is now a "top hit" which seems to be anything from your history that matches the text you entered.

None of the options in Safari Preferences allow you to disable this functionality. Even after turning off "Safari suggestions" and "preload top hit", I still see Top Hit.

How do I turn it off without deleting the item from my browser history?

9
  • Did you check safari preferences? – anki Sep 24 '19 at 20:22
  • Yes, none of the options there allow you to disable this functionality. Note that “top hit” is different from “top sites”. – Michael Wu Sep 24 '19 at 20:23
  • 1
    As I’ve mentioned, none of those options are relevant to “top hits”. Even after disabling all of those, “top hits” are still the first item in the search drop down. – Michael Wu Sep 24 '19 at 20:28
  • 2
    Short of disabling history, I don't think there's anything you can do sadly. I've scoured Safari's preferences .plist (defaults read -app Safari) and found nothing that seems promising. The closest is DidMigrateToCoreSpotlightBasedHistorySearch, but since it's a migration not a preference, I don't think this is useful. – JMY1000 Sep 25 '19 at 4:41
  • 2
    This behavior has been driving me mad for the last couple of weeks and I'm glad to find out it wasn't just me. I think there's been a change in the unified field completion where it now takes into account the title of the page, but I don't see any easy ways of disabling this. I've filed FB7333211 in an attempt to bring this in front of the eyes of Safari engineers. – saagarjha Sep 30 '19 at 6:11

You must log in to answer this question.

Browse other questions tagged .