0

I have a MacBook Air with a British English keyboard layout and a bluetooth keyboard with a Norwegian layout.

I would like to use my bluetooth keyboard for when I am typing in Norwegian, and the inbuilt keyboard for when I am typing in English.

However, when I try to use the Norwegian keyboard to type a Norwegian letter, it instead types the symbol occupying the same position on the British keyboard.

This affects all the keys on my external keyboard. My computer effectively treats my Norwegian keyboard as though it were a British one.

Instead, I would like my computer to always treat my external keyboard as a Norwegian keyboard and to always treat my inbuilt keyboard as a British one.

Can you show me how to set up my computer in this way, please?

Thank you in advance

1
  • You can easily switch the layout between the two via the “flag menu” at the top right of the screen or via a keyboard shortcut such as control plus space. For this to happen automaticslly requires you to install the Karabiner app. Sep 22, 2019 at 22:15

1 Answer 1

1

Go to System Preferences and to Keyboard. When that pane comes up, select the Input Sources tab. This is where you choose a foreign keyboard. See figure below.

enter image description here

You can see in the figure what the keyboard looks like for the Russian language. By clicking the 'Show Input menu in menu bar' you'll have a menu item to view the foreign keyboard whenever you want.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .