6

I am using the Deezer app music. It worked well, I could use the media buttons to control play/pause/next track/previous track. But a few days ago, (after an macOS update?) now when I hit play/pause it launches iTunes instead of controlling the Deezer app that is already running and playing music. It was correctly functioning before, so I don't know where this change of behaviour is coming from. This is very annoying as it makes the Deezer almost unusable as I have to bring it to front to control it.

1
  • Question re-opened, please post the solution you've found as an answer below. – nohillside Sep 23 '19 at 11:06
17

Found the answer on the Deezer community forum:

You have to allow Deezer the accessibility rights, go to:

  • System Preferences
  • Security and Privacy
  • Privacy tab
  • Choose "Accessibility"
  • Add "Deezer" to the allowed software

You'll have to unlock the configuration by clicking on the lock and enter your system password.

The original answer can be found here.

4
  • Did it on Catalina, still launches iTunes :( – artem Jun 7 '20 at 19:54
  • 1
    @artem I may be a little bit late to the party but just tried this on Catalina and worked like a charm. – mrbolichi Jul 27 '20 at 14:22
  • 1
    @artem Even after rebooting? – Thiago Gouvea Aug 4 '20 at 12:37
  • it launches Apple Music for me too, but if Deezer is running, it will take the media key presses – mut1na Jan 9 at 13:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .