1

I tried to install Linux Mint on an external drive and the installer crashed.

I used Gparted to delete the two partitions I had created (one ExFat, the Other Ext4) and rebooted into MacOS Mojave. I then tried to add the free space to an APFS Partition name "Shared" and it would not let me.

From other answers it appears another partition is preventing it but I can't tell which one. Would someone please tell me the EXACT commands to enter in Single user mode (Command-S, right?) to fix it?

The output of diskutil list is:

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         499.0 GB   disk0s2
   3:       Microsoft Basic Data iMac Windows 10         501.0 GB   disk0s3

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +499.0 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh 1TB           161.7 GB   disk1s1
   2:                APFS Volume Preboot                 44.0 MB    disk1s2
   3:                APFS Volume Recovery                510.4 MB   disk1s3
   4:                APFS Volume VM                      5.4 GB     disk1s4

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *16.0 TB    disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS Mac Backup 1            2.0 TB     disk2s2
   3:                 Apple_APFS Container disk3         10.2 TB    disk2s3
   4:                  Apple_HFS Emergency Boot 1        501.9 GB   disk2s5
   5:                 Apple_Boot Recovery HD             650.0 MB   disk2s6

/dev/disk3 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +10.2 TB    disk3
                                 Physical Store disk2s3
   1:                APFS Volume Shared                  1.9 TB     disk3s1

Diskutil Drive Partition Window

  • Check the actual partitioning with diskutil list in Terminal & add to your question. – Tetsujin Sep 21 at 16:14
  • Please add also output of sudo gpt show disk2 This will show the actual sectors the partitions start on and so where the free space is. You seem to be missing disk2s4 in diskutil list – lx07 Oct 4 at 7:26
  • @lx07 Attempting to execute "get show disk2" resulted in "Suspicious MBR at sector 0" "bad map" and "unable to open disk2" appearing on consecutive lines. Does this mean I have to completely wipe the drive to repair it? – Bryan Dunphy Oct 4 at 20:01
  • No you don't need to wipe the drive - it just means that the disk has a hybrid member for some reason. You can delete it and create a protective member using gdisk as described in this answer by the tools author without losing any data : superuser.com/questions/1140907/… (i.e. sudo gdisk /dev/disk2 then x n w y) – lx07 Oct 4 at 20:45
  • Is disk2 the only disk you want to change? – bmike Oct 6 at 15:15

You must log in to answer this question.

Browse other questions tagged .