26

Starting on September 20, 2019, my macOS 10.14.6-equipped iMac began asking me to enter the password for two Google accounts I've long had connected to the machine.

I clicked the notification bubble and it took me to the Internet Accounts area of System Preferences. Upon clicking one of the two Google accounts a dialog was presented by System Preferences that informed me I had to complete password entry for the Google account in Safari. Clicking OK opened Safari but no authorization page is every loaded.

I deleted the accounts and attempted to re-add them to the Internet Accounts settings but the problem remains. I'm stuck in a loop.

Prior to this occuring, I updated Safari on the iMac. No changes were made to either Google account by me prior to this occuring (though Google could have made changes quietly without my knowledge).

You can view the problem occuring in this screen capture video I took: https://youtu.be/wIJaBCyp_5I

Both of these Google accounts have long used 2FA if that is of any help helping me solve this problem. I would use an app-specific password here, but that doesn't appear to be an option when adding a Google account in the Internet Accounts pane of System Preferences.

How can I fix this and get these accounts re-added to macOS?

  • 2
  • Safari Version 12.1.1 (14607.2.6.1.1) could do it nicely I think. Can you try to add them as IMAP accounts, not as Google specifically. I dont really remember the results, but one of them settled the thing. Also, was safari open(even with no window) at the time you clicked OK to open safari. I could give you the link if I ascertain that it's anonymous or say general. – ankii Sep 20 at 23:56
  • I can do an app password and use that for IMAP to connect Mail but Calendar gets left out if I do this. – Ian C. Sep 20 at 23:57
  • 2
    This issue appears to be related to the Safari 13.0 (14608.1.49) update. I've filed a bug with Apple. – Ian C. Sep 21 at 0:15
  • 1
    Yes, I upgraded to Safari today and got this issue. My safari version is 13.0 (14608.1.49) – ttt Sep 22 at 14:07
23

Safari 13.0.1 fixes this issue.

From the release notes:

  • Fixes an issue that prevents signing into Google in Internet Accounts in System Preferences

To install Safari 13.0.1:

Go to System Preferences > Software Update to install the 13.0.1 update. You'll need to restart your Mac after the installation for the Google authentication problem to go away.

If pressing the "Open Safari" button in the Internet Accounts pane of System Preferences fails to open Safari, open Safari yourself and the problem shoudl rectify itself. Safari does not need to be made the default browser for the system.


As of the time this was posted, September 20 2019, there was no known solution to the problem. Safari 13.0 broke the authentication workflow from System Preferences with Google account authentication if you use 2FA on your Google account.

The problem has been reported to Google and Apple via their official bug feedback channels.

Partial workaround

A partial workaround to the problem can be had for Mail.app and Notes.app if you add your Google account as a generic "Mail Account". For this to work you'll need to generate an application-specific password in your Google account and use this app-specific password with your Google email address to link the account to Mail.app and macOS.

To generate an application specific password for your Google account (from Google's official documentation):

  1. Go to your Google Account.
  2. On the left navigation panel, choose Security.
  3. On the "Signing in to Google" panel, choose App Passwords. If you don’t see this option:
    • 2-Step Verification is not set up for your account.
    • 2-Step Verification is set up for security keys only.
    • Your account is through work, school, or other organization.
    • You’ve turned on Advanced Protection for your account.
  4. At the bottom, choose Select app and choose the app you’re using.
  5. Choose Select device and choose the device you’re using.
  6. Choose Generate.
  7. Follow the instructions to enter the App Password. The App Password is the 16-character code in the yellow bar on your device.
  8. Choose Done.

To use this password with macOS:

  1. Navigate to System Preferences > Internet Accounts and click the Add Other Account... at the bottom of the list
  2. Select Mail account from the list
  3. Fill out the fields:
    • Name:
    • Email Address:
    • Password:
  4. Click the Sign In button to complete the process. You'll be able to connect to Mail and Notes with this approach.

Unfortunately this approach won't work to make a Calendar connection from Calendar.app to your Google calendar.

  • 6
    Please update here if it gets fixed or there's a better solution. – Mohammad Dashti Sep 21 at 19:18
  • 1
    If Apple would honor the default browser settings, maybe we wouldn't be having this problem. Also, it seems amazing that at least one of the Apple engineers didn't catch this... surely they use Gmail for personal email as well. – Michael Teter Sep 23 at 9:13
  • Seriously Apple? You broke Gmail again?! – n1000 Sep 24 at 7:23
7

Safari 13.0.1 has been released and addresses this issue. I have verified that I can add Google accounts myself.

Edit: if the update doesn’t fix it, restart your computer

  • 1
    Doesn't work for me for a normal Gmail account with Safari 13.0.1. "Open Safari" button stays pressed, nothing happens. – Dennis Krupenik Sep 24 at 18:06
  • Hmm, I clicked it and a window appeared. Try restarting perhaps. – Ezekiel Elin Sep 24 at 18:24
  • I can confirm that upgrading to 13.0.1 fixed the issue, but it did require a restart. – Steve Nay Sep 24 at 20:31
  • It's been working for me after applying 10.14.6 Supplemental Update (that involved restarting) – Dennis Krupenik Sep 25 at 19:12
1

Temporary solution: Re-download the 10.14.6 MacOS from the apple store and reinstall it. You only need to wait for about 30 minutes. After reinstalling, don't update Safari from the Apple Store for now. After I waited for 3 days, this is the fastest solution...

0

A partial workaround to the problem: for Mail.app and Notes.app you can add your Google account as a generic "Mail Account". For this to work you'll need to generate an application-specific password in your Google account and use this app-specific password with your Google email address to link the account to Mail.app and macOS.

-1

Google Calendar has no fix as of yet, You could try CalDAV but it no longer works, for Contacts add a CardDAV account, set the Account Type to Manual.

Server Address: www.google.com User name: Your email address Password: Your google password

You might get an unable to connect to account error, to fix that, You need to enable Low Security App access.

-2

I just installed Safari 13.0.1 and this issue is fixed. You might want to restart the Calendar app for it to be working

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .