0

So my 2012 iMac has been unusually cranky the past couple days and did not respond to the usual reboot I give when this happens, so I decided to reset the PRAM at the advice of many articles.

Everything seemed to go OK until I tried logging in. I know for a fact that I was using the correct username and password. But it would not log me in.

I logged in as the main user account and looked in Sys Pref --> Users and Groups and the user I always use was nowhere to be found. Luckily I keep that user's home directory on a drive separate from the the OS, so I didn't lose anything there.

As the main user (that I WAS able to log in with), I created a new account with the same name as my missing account and set the home directory the same one the previous one used.

When I restarted and logged in as my previous user (the one I use all the time), it worked this time, but I'm now getting all these dialog boxes saying XXXXX wants to se the "Local Items" key chain. My account password is not working (and I set it to the same thing it was previously) and now I can't access a bunch of apps such as safari and office.


EDIT

I attempted to run First Aid from Disk Utility on all drives and partitions with all apps closed. Everything came back fine except for 1 partition on my 2-year-old 1TB HDD. It's the partition I store all my files (including home directory) on. The OS is installed on another partition on that drive. Here's the error screen

enter image description here

Anything else I should be trying?

Can anyone point me in the right direction for resetting this password... or syncing with my user account? Also, I don't know that the performance issues have cleared up either. Should I try resetting SCM and NVRAM?

  • Stop playing with things before you make them even worse. SMC & NVRAM were not the cause of your issue [nor will they be the cure]. Check your drives for corruption as a first step. Your compounding any issue by duplicating one user has caused your keychain to be out of sync. The keychain no longer belongs to the user you think it does. – Tetsujin Sep 19 at 18:38
  • I get that just naming that account the same thing doesn't make it the same actual account. Is there any way to restore the lost one or merge they keychain with this new account? I just ran Disk First Aid on all drives and partitions. Results updated in OP. Any ideas? – Daveh0 Sep 19 at 18:58
  • Run Disk Utility from Recovery, so no 'system' structures are mounted. I'm not certain how moved system/user folders are handled, but that would make sure they're not in use. – Tetsujin Sep 19 at 19:06
  • did that for all drives and partitions again. no errors reported. Any other steps you recommend for checking drive corruption? Any idea what I can do about this keychain issue? – Daveh0 Sep 19 at 19:26
  • Next suggestion would be to check SMART status. The user & keychain are not tied to the user name per se, but to the user ID. Your first user would have been 501, subsequent would be increasing from that number. I honestly don't know how the OS would try to deal with the conundrum you've set it. It may be simpleer to just nuke it all & recover from Time Machine. BTW, is that Catalina? Separate boot & data drives, or what? It's hard to figure out from the single data point. – Tetsujin Sep 19 at 19:29

You must log in to answer this question.

Browse other questions tagged .