1

Are there any firmware updates, or other changes, done by the 10.14 installer that could cause a 10.10 system to not work?

To quell all the "why would you want to do that?" questions, here's the scenario:

At my work I have a Late 2013 Retina MacBook Pro (model MacBookPro11,3) that, until recently, I kept on 10.10 on in order to use a suite of tools for work that interface with some older hardware. It's the only Mac we have.

We just managed to buy a newer version of the hardware. It's tools are modern and can run on 10.14 without issue. However that older hardware will be moving to another room to be used elsewhere so we still need to interface with it to configure it. The older tools don't support the new hardware and can't run on 10.11 or above, the newer tools don't support the older hardware and require "a modern version of MacOS" (the developer recommends 10.14, doesn't say anything about previous versions).

A VM is not an option as there isn't the ability to do FireWire passthrough to a VM with the ThunderBolt to FireWire adapter.

My plan is to dual-boot the machine with a 10.14 install and a 10.10 install. To configure the new hardware, boot to 10.14. To configure the old hardware, boot to 10.10.

My worry is that running the 10.14 installer will upgrade firmware on the machine to a version that is incompatible with 10.10, and thus the dual-boot would not work.

  • I think you've miswritten, "The newer tools don't support the old hardware and can't run on 10.11 or above, the older tools don't support the newer hardware and don't work above 10.10" Is the first half of that wrong? Also, are either tools/hardware compatible with Windows? As for firmware updates, you should be okay since your MBP originally shipped with OS X Mavericks. Another option may be using an external boot disk rather than dual booting from the same physical drive. Finally, if it was me, I'd ask the developer which older versions of macOS the new tools will run on? – Monomeeth Sep 19 at 11:05
  • @Monomeeth see this is what happens when I decide to write this after a long day at work :) Fixed. And no, unfortunately the tools don't work on Windows. The developer doesn't seem to want to talk to us about the old hardware. Something about it having been out of support for more than 5 years. – lightbord Sep 19 at 14:15
  • I get that, but the Developer should be willing to advise what versions of macOS the new tools/hardware work with? I know they recommend Mojave, but this may only be a general recommendation rather than because their software works better on Mojave. I ask only because something like macOS Sierra may be a preferable option since going to Mojave will require formatting the internal SSD into the APFS format. – Monomeeth Sep 19 at 21:49
2

I haven't heard about such incompatible firmware updates.

I have dual-booted 10.14 (Mojave) and 10.11 (El Capitan) on the 2013 Retina MacBook Pro, which is almost the same configuration - and that worked without problems as far as I recall.

  • I will mark this as the answer once I do it and if it works. – lightbord Sep 19 at 14:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .