4

I am having a version of the battery not charging issue on my Macbook Pro 2018 (13-inch, Four Thunderbolt 3 Ports). The symptoms are somewhat different from related issues, such as in this post. I am experiencing the following symptoms:

  1. While power adapter is plugged in, the battery drains, and my system battery indicates "Battery not charging..." even when there are no apps using significant CPU cycles.
  2. The system continues to list the power adapter as the battery source even after I have unplugged it.
  3. I no longer hear the power chime when connecting to a power source.
  4. Battery condition is normal.

I have already tried:

  • Resetting NVRAM and SMC as suggested here, multiple times.
  • Attempting to power with different adapters and combinations of third-party USB-C hub accessories.
  • Booting in safe mode

Bottom line, nothing works. Is there something obvious that I haven't tried?

Update Apparently some of my USB-C/Thunderbolt 3 ports have ceased to function as well. This is starting to look more and more like a hardware issue related to the USB-C/Thunderbolt controller.

Even further update A trip to my local Apple authorized repair shop (after my battery had completely drained) revealed that:

a. the battery was able to be charged after some period of "rest" b. Apple Hardware Diagnostics indicated nothing technically wrong with the machine

Classic bizarro intermittent problem. The only other common thread I've discovered is this: every time this behavior has occurred, I have been using an accessor hub called "dodocool Aluminum Alloy 7-in-1 Multiport Hub with dual USB-C Connectors, model: DC53. I'm starting to suspect that this accessory is at least a necessary cause of the behavior.

It looks like enter image description here

I will update if the problem persists in the absence of this hub.

1

I don't fully agree with the steps outlined in the article you reference for resetting the SMC on a MacBook with the T2 security chip installed. Instead, try the following.

Resetting the SMC on a MacBook Pro with T2 chip installed

  1. Fully shut down your MBP.
  2. Press and hold the power button for at least 10 seconds
  3. Let go of the power button and wait 5 seconds
  4. Power up your MBP again

Once you've reset the SMC see if you can charge your MBP. If it's still misbehaving, reset the SMC again but with the following steps instead:

  1. Fully shut down your MBP.
  2. Press and hold the right shift key and the left option and control keys for 7 seconds before then also pressing and holding the power button (or Touch ID button) down for another 7 seconds (i.e. the keys will end up being held down for 14 seconds, the power button for 7 seconds)
  3. Let go of all three keys and the power button
  4. Wait 5 seconds
  5. Power up your MBP again

Now test your MBP again. If you still can't get it charging then it's time to test your hardware with Apple Diagnostics.

Running Apple Diagnostics

Your model MBP uses Apple Diagnostics to test its hardware. You can do this as follows:

  1. Fully shut down your MBP
  2. Restart your MBP
  3. Immediately press the D key and keep it down until you see the Diagnostics screen appear
  4. Wait for Diagnostics to finish (this typically only takes a few minutes)
  5. Once complete, one of two things will appear on the screen:
    • a No issues found message
    • a brief description of any errors found plus further instructions
  6. If the diagnostics test does find errors, take a note of what they are

Note: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

If after doing all of the above you still have no joy, then it's time to contact Apple directly.

  • Thank you @Monomeeth and I wish I could have tried out your additional suggestions (which were not provided when I called Apple support, by the way) before my battery was completely drained. Alas, now it's at the shop as there are literally 0 coulombs left in that poor battery! :0 – mayosten Sep 18 at 23:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .