Since upgrading to Lion, I get this error every time I start up:

enter image description here

I've read the answers suggested here, but they seem to indicate that it's the presence of a second device that's causing the problem. The only USB device I have plugged in to my laptop is an external keyboard. I'm not sure how that's using too much power, but it's disabled my other USB ports.

Is there any way to fix this?

  • Do you still get the message when the external keyboard is not attached to a USB port on the laptop? – iskra Jan 16 '12 at 16:29
  • Good question; I'll have to unplug it and restart to see - the error only occurs at startup. – EmmyS Jan 16 '12 at 17:08
  • OK, I just restarted without the external keyboard, and I still get the error message. But again, this never happened before the upgrade to Lion, and all of my USB ports used to work, so I don't know why a software update would start messing with hardware. – EmmyS Jan 16 '12 at 17:25

It could be a corrupt USB kernel extension. I'd try booting to Safe Mode:

  1. Turn off your Mac.
  2. Turn it back on and before you see the Apple logo on your screen, press and hold the Shift key until the Apple logo appears.
  3. A progress bar should appear below the Apple logo - during this time your Mac is performing a directory check and loads only necessary Apple kernel extensions (among other small things).

A feature of Safe Mode is that it reloads the kernel extensions from scratch, instead of from a cache file. It could be that during the Lion upgrade a kernel extension was damaged and has been cached afterwards.

Try the Safe Mode boot and see how it goes.

Good Luck!

  • 1
    Yes! It worked. Thanks so much. Half of my office was upgraded at the same time I was, and everyone was getting that error. I'm passing this along. – EmmyS Jan 18 '12 at 21:00
  • Superb! Pleased to hear it =) – Dan Barrett Jan 18 '12 at 21:04
  • I had the same problem with my iMac since last night and Safe Mode boot as suggested by Dan Barrett worked. – user25206 Jul 12 '12 at 21:49
  • 1
    This didn't work for me, but disconnecting a faulty cable did, as explained in another answer. – Henrik N Aug 18 '12 at 20:34
  • If lots of people are getting this error it poses the question how were they upgraded? Perhaps your IT department has a bad install or the incorrect install they are putting on all the machines? – Justsomeguy Nov 27 '12 at 5:09

In my case one of the metal prongs (cut out of the metal casing on the side without the connection pins) inside a usb port had been bent and was touching the other side, once this was corrected with a small screwdriver all my USB ports worked again and this error message disappeared.

This is probably the problem if you cannot fully insert a usb plug into any of the ports.


Another reason that this happens is when the device's USB cable is ripped/torn/ has a small hole. I had gone to sync my iPad with iTunes and suddenly was getting this message. The only other thing I had plugged into my computer was my printer, so I disconnected the printer. Then I tried again, but still got the message.

I was stumped so I started looking at the USB cable itself, and sure enough, there was a tear in it, and it was quite small but it was a tear in the cable that protects the wires inside. That was enough for it to cause the problem, but to be sure, I used my extra USB cable and was able to sync no problem.

After syncing with the "good" usb cable, I tried to sync with the bad one, and sure enough I got the error message again.

Sometimes you don't always see rips or tears in those cables. Maybe it got pinched behind something or whatever, but the smallest in it is enough to do it.

So that is another reason why some might get that " because a usb device was drawing too much power from your computer, one or more of your USB devices have been disabled" messages.

  • I had that response on another forum, but it's not the case. Due to other issues, I ended up with a completely new machine. I use the exact same keyboard with the same usb cable on the new machine with no issues. – EmmyS May 21 '12 at 15:41
  • Good advice. Got this error on Mountain Lion. MacBook Air connected to Apple Cinema Display as USB hub with some stuff connected. I tried unplugging one thing, then disconnecting and reconnecting the computer <-> display USB cable until the error went away. Turns out my iPhone sync cable (even with no phone connected) was the culprit. – Henrik N Aug 18 '12 at 20:32

I had the same issue with my old MacBook; one of the USB ports was totally fried. Doubt it's Lion-related, but I can't rule that out for sure.

  • But it only started happening when I upgraded to Lion. How could it not be Lion-related? – EmmyS Jan 18 '12 at 16:30

I had the same problem. I tried to plug my ipad into my computer and every time it gave me that error message. The strange thing was that I rebooted my computer using safe mode and it worked, but then i put it back in the regular mode and got the same message again. So then I took out the usb and examined it, and i saw what looked like a speck of dust inside it, so i blew into it until i couldnt see the speck anymore and then reinserted it and then it worked.


Just got the same problem today with my iPad. After inspection it looks like the problem is in the cable. I have inserted it directly in the power unit and the charging indicator became very sensitive as I moved the cable up and down.

It is a shame that Apple supplies expensive iPads with that kind of cables.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .