0

I have an iPhone 6 running iOS 12.4.1.

I have a paltry data plan ($$$), so I've turned off iMessage in Settings -> Messages.

iMessages show up in blue in Messages app; regular text messages show up in green.

So far, so good. I can still send/receive messages when I'm out and about, and I'm not leaving data turned on and thus chewing through it quickly (and have it available if I need it, such as for driving directions).

Now, here comes the part I don't understand. Although I'm connected to my home network almost the time, much to my surprise, when I do turn on data, I get a number of queued messages. They all seem to be group messages, and show up in grey in Messages.app. [These groups may have been created before I switched off iMessage, if it makes a difference]

This is unbelievably frustrating. I had no idea I was missing messages. I don't get it -- why don't they come through as normal text messages, or come through over my WiFi? Why are they only available when I turn on ridiculously expensive cellular data?

More to the point, is there a way I can get them to come over WiFi, so I don't miss them and don't pay extra for them?

  • Which country are you in as many (most?) the receiver of a phone message does not pay so I don't see why you turn your data off. – user151019 Sep 18 at 9:24
  • @Mark, I'm in Canada. With iMessage on, you only get messages when you have an internet connection -- WiFi or Cellular Data. If I turn on my cellular data, it gets burned through quickly (apps using it in the background, I suppose) and gets costly quickly. If I turn it off, I don't get text messages when I'm out and about. – Clinton Blackmore Sep 18 at 18:03
1

A one-to-one text message uses SMS. A group message uses MMS and this requires data. You would likely have the same issue if someone texts you a picture directly as this also uses MMS.

Check with your service provider though, as some include picture messaging (i.e. MMS) for "free" and don't count it as data. In which case you could leave iMessage enabled for data. YMMV.

-1

Try adding your apple ID to your send and receive address.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 1
    Apple ID is not used for SMS or MMS. – duskwuff Sep 17 at 19:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .