1

I have a USB-C screen that offers hub functionnality (usb, audio, ethernet). While the screen is perfectly connected and works like it should for usb, audio, and of course video, the ethernet connection doesn't work anymore.

I know it's not the screen because:

  • I have succesfully tested it on another MBP,
  • I have actually two screens of the same model and tried both.

This used to work but stopped working all of a sudden. I reset the SMC, and tried to plug the screen on different USB-C ports.

It is worth mentioning that the MacBook detects the connection if I plug the Ethernet cable via the USB-C Ethernet adaptor…

What else should I try (appart from reinstalling macOs)?

  • 1
    You could try to remove the adapter in System Preferences under Networking. It should re-appear, but if not, you can always add it. Another thing to check is that it's coming up in System Profiler. You can check under thunderbolt, or USB, or networking. If it's not coming up under there, something is more seriously wrong since the Mac isn't even recognizing the device. – technogeek1995 Sep 17 '19 at 16:52

You must log in to answer this question.

Browse other questions tagged .