1

When I turn off notifications for Messages on macOS, I don’t get a vibration or sound from my iPhone on incoming texts when I’m using my Mac at the same time. It still delivers them silently there, assuming I’ve seen the message on my Mac.

Is there any way to fix this?

  • 1
    For clarification.. If you don't have Messages front-most on the Mac & ignore the incoming message, does it show on the phone after a minute or two? By default a message will notify on the last-used device, then wait a min or 2 before notifying on all others. If you have Messages front-most, of course, you are deemed to have read it if that conversation was also front-most. Check the blue dot. – Tetsujin Sep 14 at 10:44
  • @Tetsujin Messages on the Mac is not even open, in addition to the notifications being turned off, yet I don’t receive a notification/buzz on either device. – Simon Sep 16 at 12:44
  • & you've checked the notification section on the phone itself is still on? – Tetsujin Sep 16 at 12:54
  • @Tetsujin yes, I receive notifications as normal when I’m not using the computer. – Simon Sep 25 at 13:10

You must log in to answer this question.

Browse other questions tagged .